aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libXcomposite
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-12-27 09:34:43 +0800
committeranholt <anholt@FreeBSD.org>2003-12-27 09:34:43 +0800
commit9987f93fc496f8350f07a21ed594a5639095521f (patch)
tree33fa96845a8404501a1a54e8f254428a5b93ae93 /x11/libXcomposite
parent2f0aae31191bb024a4dc2ed0a673eb2e38948bd8 (diff)
downloadfreebsd-ports-graphics-9987f93fc496f8350f07a21ed594a5639095521f.tar.gz
freebsd-ports-graphics-9987f93fc496f8350f07a21ed594a5639095521f.tar.zst
freebsd-ports-graphics-9987f93fc496f8350f07a21ed594a5639095521f.zip
New port: Prerelease version of libXcomposite from freedesktop.org:
X Composite extension library Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11/libXcomposite')
-rw-r--r--x11/libXcomposite/Makefile33
-rw-r--r--x11/libXcomposite/distinfo1
-rw-r--r--x11/libXcomposite/files/patch-Makefile.in11
-rw-r--r--x11/libXcomposite/pkg-descr6
-rw-r--r--x11/libXcomposite/pkg-plist6
5 files changed, 57 insertions, 0 deletions
diff --git a/x11/libXcomposite/Makefile b/x11/libXcomposite/Makefile
new file mode 100644
index 00000000000..362e4c743b9
--- /dev/null
+++ b/x11/libXcomposite/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libXext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXcomposite
+PORTVERSION= 1.0.0.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Composite extension library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xfixes.pc:${PORTSDIR}/x11/libXfixes
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/compositeext.pc:${PORTSDIR}/x11/compositeext \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.0
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXcomposite/distinfo b/x11/libXcomposite/distinfo
new file mode 100644
index 00000000000..7c0fc2e77a1
--- /dev/null
+++ b/x11/libXcomposite/distinfo
@@ -0,0 +1 @@
+MD5 (libXcomposite-1.0.0.p1.tar.bz2) = a536193345735628ac9ee2045e53a447
diff --git a/x11/libXcomposite/files/patch-Makefile.in b/x11/libXcomposite/files/patch-Makefile.in
new file mode 100644
index 00000000000..5568a916fab
--- /dev/null
+++ b/x11/libXcomposite/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Nov 13 13:55:20 2003
++++ Makefile.in Thu Nov 13 14:07:16 2003
+@@ -189,7 +189,7 @@
+ libXcompositeincludedir = $(includedir)/X11/extensions
+ libXcompositeinclude_HEADERS = Xcomposite.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xcomposite.pc
+
+ EXTRA_DIST = xcomposite.pc.in autogen.sh
diff --git a/x11/libXcomposite/pkg-descr b/x11/libXcomposite/pkg-descr
new file mode 100644
index 00000000000..312a9789080
--- /dev/null
+++ b/x11/libXcomposite/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Composite extension library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXcomposite/pkg-plist b/x11/libXcomposite/pkg-plist
new file mode 100644
index 00000000000..1fe48797e5d
--- /dev/null
+++ b/x11/libXcomposite/pkg-plist
@@ -0,0 +1,6 @@
+include/X11/extensions/Xcomposite.h
+lib/libXcomposite.a
+lib/libXcomposite.la
+lib/libXcomposite.so
+lib/libXcomposite.so.1
+libdata/pkgconfig/xcomposite.pc