aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libgnome
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-12-15 14:22:28 +0800
committersobomax <sobomax@FreeBSD.org>2001-12-15 14:22:28 +0800
commit4bd3ee1e35359152b7e33eb503f1074094a3e247 (patch)
tree38c7ae9b24fb7cc3a6cf5f9eaa62b203ebff9847 /x11/libgnome
parentebd8108e0fa0ebdbb8702142ab0d51f35027f5d1 (diff)
downloadfreebsd-ports-graphics-4bd3ee1e35359152b7e33eb503f1074094a3e247.tar.gz
freebsd-ports-graphics-4bd3ee1e35359152b7e33eb503f1074094a3e247.tar.zst
freebsd-ports-graphics-4bd3ee1e35359152b7e33eb503f1074094a3e247.zip
Fix a null pointer dereferencing bug in gtk-xmhtml library observed when
browsing evolution documentation. Bump PORTREVISION.
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile2
-rw-r--r--x11/libgnome/files/patch-gtk-xmhtml::images.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index da5ed840c08..4b9c1743272 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomelibs
PORTVERSION= 1.4.1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-libs
diff --git a/x11/libgnome/files/patch-gtk-xmhtml::images.c b/x11/libgnome/files/patch-gtk-xmhtml::images.c
new file mode 100644
index 00000000000..6e24a95c4b6
--- /dev/null
+++ b/x11/libgnome/files/patch-gtk-xmhtml::images.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- gtk-xmhtml/images.c 2001/12/15 05:19:03 1.1
++++ gtk-xmhtml/images.c 2001/12/15 05:19:22
+@@ -2393,7 +2393,7 @@
+ {
+ if(!html->html.xcc)
+ _XmHTMLCheckXCC(html);
+- image->xcc = html->html.xcc;
++ xcc = image->xcc = html->html.xcc;
+ }
+ }
+