aboutsummaryrefslogtreecommitdiffstats
path: root/x11/luit
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2012-04-24 19:07:28 +0800
committernaddy <naddy@FreeBSD.org>2012-04-24 19:07:28 +0800
commit912676f74f5b9212c923469130b3783b5b78c4cd (patch)
tree3a67a4cf21b0527514881045ebe8e177312af26a /x11/luit
parent5ff46f915ca7469c972af024f13cbcae32d99d46 (diff)
downloadfreebsd-ports-graphics-912676f74f5b9212c923469130b3783b5b78c4cd.tar.gz
freebsd-ports-graphics-912676f74f5b9212c923469130b3783b5b78c4cd.tar.zst
freebsd-ports-graphics-912676f74f5b9212c923469130b3783b5b78c4cd.zip
Make sure openpty() is used to allocate a PTY.
This fixes luit on RELENG_7 and removes any need for setuid.
Diffstat (limited to 'x11/luit')
-rw-r--r--x11/luit/Makefile19
1 files changed, 4 insertions, 15 deletions
diff --git a/x11/luit/Makefile b/x11/luit/Makefile
index 4c4c7743be9..b9e1a3c831b 100644
--- a/x11/luit/Makefile
+++ b/x11/luit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= luit
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
@@ -15,25 +16,13 @@ COMMENT= Locale and ISO 2022 support for Unicode terminals
XORG_CAT= app
USE_XORG= x11 fontenc
-CFLAGS+= -DBSD
CONFIGURE_ARGS= --datadir=${LOCALBASE}/lib
+# Use openpty(), FreeBSD 7 has grantpt but not /dev/ptmx
+CONFIGURE_ENV= ac_cv_func_grantpt=no
+
PLIST_FILES= bin/luit
MAN1= luit.1
-.if !defined(WITH_SETUID_LUIT)
-pre-everything::
- @${ECHO_MSG} "If you want to use xterm with locales in a secure manner, luit must be"
- @${ECHO_MSG} "installed setuid. If you want to do this, define WITH_SETUID_LUIT when"
- @${ECHO_MSG} "installing this port (either in /etc/make.conf or on command line with"
- @${ECHO_MSG} "install target)."
-.endif
-
-post-install:
-.if defined(WITH_SETUID_LUIT)
- ${CHOWN} root:wheel ${PREFIX}/bin/luit
- ${CHMOD} 04711 ${PREFIX}/bin/luit
-.endif
-
.include <bsd.port.mk>