aboutsummaryrefslogtreecommitdiffstats
path: root/x11/powershell/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-06-08 01:15:12 +0800
committersobomax <sobomax@FreeBSD.org>2000-06-08 01:15:12 +0800
commit83253c141494281cf5de31ef5ef51dd9ed34bada (patch)
treef4d4d6ee1d39b6d2aec8d5574d38a8cee1b34016 /x11/powershell/Makefile
parent69713d1490cfb08d26f8f265eceb1bb689b116c4 (diff)
downloadfreebsd-ports-graphics-83253c141494281cf5de31ef5ef51dd9ed34bada.tar.gz
freebsd-ports-graphics-83253c141494281cf5de31ef5ef51dd9ed34bada.tar.zst
freebsd-ports-graphics-83253c141494281cf5de31ef5ef51dd9ed34bada.zip
Initial import of a powershell - a nice Gnome-based terminal emulator for the
X11 Window System. PR: 18412 Submitted by: Scott A. Moberly <smoberly@xavier.dyndns.org>
Diffstat (limited to 'x11/powershell/Makefile')
-rw-r--r--x11/powershell/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11/powershell/Makefile b/x11/powershell/Makefile
new file mode 100644
index 00000000000..ef2bfc3dc23
--- /dev/null
+++ b/x11/powershell/Makefile
@@ -0,0 +1,30 @@
+# Ports collection Makefile for: powershell
+# Date created: 6 May 2000
+# Whom: Scott A. Moberly <smoberly@xavier.dyndns.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= powershell
+PORTVERSION= 0.8
+CATEGORIES= x11 gnome
+MASTER_SITES= http://powershell.sourceforge.net/download/
+
+MAINTAINER= smoberly@xavier.dyndns.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gdk_imlib:${PORTSDIR}/graphics/imlib
+
+USE_X_PREFIX= yes
+USE_AUTOCONF= yes
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/gnome
+
+ALL_TARGET= powershell
+
+MAKE_ENV= ${CONFIGURE_ENV}
+
+.include <bsd.port.mk>