aboutsummaryrefslogtreecommitdiffstats
path: root/x11/ruby-gnome-all
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-06-03 18:55:07 +0800
committerknu <knu@FreeBSD.org>2002-06-03 18:55:07 +0800
commitac2c680ab37f4c0fdd0812c30d0d5f2b749db447 (patch)
treec1d14d2fd20a7ea8906dc2a5083df40bebce73e7 /x11/ruby-gnome-all
parentb347fc61d223ea9abad8d5a11ee9d0f39a6696fe (diff)
downloadfreebsd-ports-graphics-ac2c680ab37f4c0fdd0812c30d0d5f2b749db447.tar.gz
freebsd-ports-graphics-ac2c680ab37f4c0fdd0812c30d0d5f2b749db447.tar.zst
freebsd-ports-graphics-ac2c680ab37f4c0fdd0812c30d0d5f2b749db447.zip
Add ruby-gnome-all, the "meta-port" for Ruby/GNOME.
Diffstat (limited to 'x11/ruby-gnome-all')
-rw-r--r--x11/ruby-gnome-all/Makefile40
-rw-r--r--x11/ruby-gnome-all/pkg-comment1
-rw-r--r--x11/ruby-gnome-all/pkg-descr1
-rw-r--r--x11/ruby-gnome-all/pkg-plist1
4 files changed, 43 insertions, 0 deletions
diff --git a/x11/ruby-gnome-all/Makefile b/x11/ruby-gnome-all/Makefile
new file mode 100644
index 00000000000..9046e103047
--- /dev/null
+++ b/x11/ruby-gnome-all/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Ruby-GNOME-all
+# Date created: 3 June 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-all
+PORTVERSION= ${RUBY_GNOME_PORTVERSION}
+CATEGORIES= x11 ruby gnome
+MASTER_SITES= # none
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTFILES= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= knu@FreeBSD.org
+
+#RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/gtk.so:${PORTSDIR}/x11-toolkits/ruby-gtk
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/lglade.so:${PORTSDIR}/devel/ruby-libglade
+#RUN_DEPENDS+= ${RUBY_SITELIBDIR}/gdk_imlib.rb:${PORTSDIR}/graphics/ruby-gdk_imlib
+RUN_DEPENDS+= ${RUBY_SITELIBDIR}/gdk_pixbuf.rb:${PORTSDIR}/graphics/ruby-gdk_pixbuf
+#RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/gnome.so:${PORTSDIR}/x11/ruby-gnome
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/panel_applet.so:${PORTSDIR}/x11/ruby-panel-applet
+
+# libglade depends on gtk
+# gdk_imlib depends on gtk
+# gdk_pixbuf depends on gtk
+# gnome depends on gtk, gdk_imlib
+# panel-applet depends on gtk, gnome
+
+USE_RUBY= yes
+
+.include "${.CURDIR}/../../x11/ruby-gnome/Makefile.common"
+
+NO_BUILD= yes
+
+do-install:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/x11/ruby-gnome-all/pkg-comment b/x11/ruby-gnome-all/pkg-comment
new file mode 100644
index 00000000000..435e8e10c96
--- /dev/null
+++ b/x11/ruby-gnome-all/pkg-comment
@@ -0,0 +1 @@
+The "meta-port" for Ruby/GNOME
diff --git a/x11/ruby-gnome-all/pkg-descr b/x11/ruby-gnome-all/pkg-descr
new file mode 100644
index 00000000000..435e8e10c96
--- /dev/null
+++ b/x11/ruby-gnome-all/pkg-descr
@@ -0,0 +1 @@
+The "meta-port" for Ruby/GNOME
diff --git a/x11/ruby-gnome-all/pkg-plist b/x11/ruby-gnome-all/pkg-plist
new file mode 100644
index 00000000000..549a621fec0
--- /dev/null
+++ b/x11/ruby-gnome-all/pkg-plist
@@ -0,0 +1 @@
+@comment this plist intentionally left empty