aboutsummaryrefslogtreecommitdiffstats
path: root/x11/silo/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2004-01-06 13:47:28 +0800
committerpetef <petef@FreeBSD.org>2004-01-06 13:47:28 +0800
commit35b62c155500c2de534a82891865aac8e2f9dd5b (patch)
treeea6df8826ca1edc6500e76e2770875431107f7d3 /x11/silo/Makefile
parent30de1b0be60ac454532c6cbf9ee82771b751f3e2 (diff)
downloadfreebsd-ports-graphics-35b62c155500c2de534a82891865aac8e2f9dd5b.tar.gz
freebsd-ports-graphics-35b62c155500c2de534a82891865aac8e2f9dd5b.tar.zst
freebsd-ports-graphics-35b62c155500c2de534a82891865aac8e2f9dd5b.zip
Add silo 1.0, a simple X11 launcher extensible in any programming
language. PR: 59059 Submitted by: DoubleF <doublef@tele-kom.ru>
Diffstat (limited to 'x11/silo/Makefile')
-rw-r--r--x11/silo/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11/silo/Makefile b/x11/silo/Makefile
new file mode 100644
index 00000000000..76fe0882b2d
--- /dev/null
+++ b/x11/silo/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: silo
+# Date created: 26 October 2003
+# Whom: DoubleF <doublef@tele-kom.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= silo
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= http://doublef.nm.ru/silo/sources/
+
+MAINTAINER= doublef@tele-kom.ru
+COMMENT= A simple X11 launcher extensible in any programming language
+
+USE_BZIP2= yes
+USE_XLIB= yes
+USE_XPM= yes
+USE_X_PREFIX= yes
+
+pre-everything::
+.if defined(WITHOUT_IMLIB)
+ @${ECHO_CMD} "Disabling Imlib support; only XPM images are supported"
+.else
+ @${ECHO_CMD} "You can disable Imlib support by defining WITHOUT_IMLIB"
+USE_GNOME= imlib
+.endif
+
+#SRC = silo.c
+IMG= audacitya.png audacityi.png sylpheeda.png sylpheedi.png
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/silo ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/pushbutton ${PREFIX}/bin
+ ${MKDIR} ${EXAMPLESDIR}/img/
+ ${MKDIR} ${EXAMPLESDIR}/prg/
+.for file in ${IMG}
+ ${INSTALL_DATA} ${WRKSRC}/share/img/${file} ${EXAMPLESDIR}/img/
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/share/prg/audacity ${EXAMPLESDIR}/prg/
+ ${INSTALL_SCRIPT} ${WRKSRC}/share/prg/sylpheed ${EXAMPLESDIR}/prg/
+ ${INSTALL_SCRIPT} ${WRKSRC}/share/topright.sh ${EXAMPLESDIR}/
+
+.include <bsd.port.mk>