aboutsummaryrefslogtreecommitdiffstats
path: root/x11/thinglaunch
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-07-25 23:35:52 +0800
committerjylefort <jylefort@FreeBSD.org>2005-07-25 23:35:52 +0800
commit21a60b0eeac0ebc5d4f2ba6ac699055ef58d1151 (patch)
treeb7b26f190f17f96e2fcbe0d6bbb041e77e9f5ac3 /x11/thinglaunch
parent3624f26534149cd21966b0b1472b077c3ac663dd (diff)
downloadfreebsd-ports-graphics-21a60b0eeac0ebc5d4f2ba6ac699055ef58d1151.tar.gz
freebsd-ports-graphics-21a60b0eeac0ebc5d4f2ba6ac699055ef58d1151.tar.zst
freebsd-ports-graphics-21a60b0eeac0ebc5d4f2ba6ac699055ef58d1151.zip
Add thinglaunch.
Thinglaunch is a very fast launcher program for X. You can bind it to a key in your favorite window manager, and when you want to start a program, just type its name. thinglaunch has a tiny footprint and depends only on Xlib. WWW: http://unix.freshmeat.net/projects/thinglaunch/ PR: ports/83904 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'x11/thinglaunch')
-rw-r--r--x11/thinglaunch/Makefile30
-rw-r--r--x11/thinglaunch/distinfo2
-rw-r--r--x11/thinglaunch/pkg-descr10
3 files changed, 42 insertions, 0 deletions
diff --git a/x11/thinglaunch/Makefile b/x11/thinglaunch/Makefile
new file mode 100644
index 00000000000..07ea5df234a
--- /dev/null
+++ b/x11/thinglaunch/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: thinglaunch
+# Date created: 22 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thinglaunch
+PORTVERSION= 1.03
+CATEGORIES= x11
+MASTER_SITES= http://critical.ch/distfiles/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A very fast launcher program for X
+
+USE_X_PREFIX= yes
+
+CPPFLAGS= -I${X11BASE}/include -lX11
+LDFLAGS= -L${X11BASE}/lib
+
+PLIST_FILES= bin/thinglaunch
+
+do-build:
+ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.c \
+ -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/thinglaunch/distinfo b/x11/thinglaunch/distinfo
new file mode 100644
index 00000000000..be94b206346
--- /dev/null
+++ b/x11/thinglaunch/distinfo
@@ -0,0 +1,2 @@
+MD5 (thinglaunch-1.03.tar.gz) = 3442545e91ba18e43e46638c0a3b485a
+SIZE (thinglaunch-1.03.tar.gz) = 3315
diff --git a/x11/thinglaunch/pkg-descr b/x11/thinglaunch/pkg-descr
new file mode 100644
index 00000000000..b6b8cecb1ea
--- /dev/null
+++ b/x11/thinglaunch/pkg-descr
@@ -0,0 +1,10 @@
+Thinglaunch is a very fast launcher program for X.
+
+You can bind it to a key in your favorite window manager, and when you want to
+start a program, just type its name. thinglaunch has a tiny footprint and
+depends only on Xlib.
+
+WWW: http://unix.freshmeat.net/projects/thinglaunch/
+
+- ehaupt
+ehaupt@critical.ch