aboutsummaryrefslogtreecommitdiffstats
path: root/x11/vdesk
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-05-18 14:27:43 +0800
committertrevor <trevor@FreeBSD.org>2002-05-18 14:27:43 +0800
commit7a723a3cf5f1c50d758f113dec7f04434061a4ea (patch)
treea285d2a114344a9872b42bea44bac840b19ddce9 /x11/vdesk
parentab30676fea0c4e53889fe1d56b6d95907e45711e (diff)
downloadfreebsd-ports-graphics-7a723a3cf5f1c50d758f113dec7f04434061a4ea.tar.gz
freebsd-ports-graphics-7a723a3cf5f1c50d758f113dec7f04434061a4ea.tar.zst
freebsd-ports-graphics-7a723a3cf5f1c50d758f113dec7f04434061a4ea.zip
Move vdesk port to x11 category.
Diffstat (limited to 'x11/vdesk')
-rw-r--r--x11/vdesk/Makefile28
-rw-r--r--x11/vdesk/distinfo2
-rw-r--r--x11/vdesk/pkg-comment1
-rw-r--r--x11/vdesk/pkg-descr11
4 files changed, 42 insertions, 0 deletions
diff --git a/x11/vdesk/Makefile b/x11/vdesk/Makefile
new file mode 100644
index 00000000000..aa7f1067477
--- /dev/null
+++ b/x11/vdesk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: vdesk
+# Date created: 2002-05-13
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= vdesk
+PORTVERSION= 1.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://azz.us-lot.org/files/
+
+MAINTAINER= trevor@FreeBSD.org
+
+PLIST= ${WRKDIR}/pkg-plist
+RESTRICTED= "no license"
+NO_CDROM= ${RESTRICTED}
+NO_FTP= ${RESTRICTED}
+USE_IMAKE= yes
+WRKSRC= ${WRKDIR}/vdesk
+
+pre-install:
+ ${ECHO_CMD} bin/vdesk > ${PLIST}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/vdesk ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/vdesk/distinfo b/x11/vdesk/distinfo
new file mode 100644
index 00000000000..b0d7942f836
--- /dev/null
+++ b/x11/vdesk/distinfo
@@ -0,0 +1,2 @@
+$FreeBSD$
+MD5 (vdesk-1.1.tar.gz) = c4712935be58a1bfe5de2b135632f4ce
diff --git a/x11/vdesk/pkg-comment b/x11/vdesk/pkg-comment
new file mode 100644
index 00000000000..bc272d55d0a
--- /dev/null
+++ b/x11/vdesk/pkg-comment
@@ -0,0 +1 @@
+Command-line utility for setting up and using virtual desktops
diff --git a/x11/vdesk/pkg-descr b/x11/vdesk/pkg-descr
new file mode 100644
index 00000000000..cd2566bef8b
--- /dev/null
+++ b/x11/vdesk/pkg-descr
@@ -0,0 +1,11 @@
+This is a small command-line utility for setting up and using virtual
+desktops.
+
+from the Web page:
+
+ invoke it as vdesk <desktop number> to switch to a desktop,
+ or vdesk <desktop number> <window id> ... to move windows
+ to a desktop, where desktop 0 means that the window should
+ be made sticky.
+
+WWW: http://azz.us-lot.org/code.html