aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xcb-util
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2008-02-17 01:17:44 +0800
committeralepulver <alepulver@FreeBSD.org>2008-02-17 01:17:44 +0800
commitb2ef5ecad04776d84a13ca59f2b2e1941b395c5b (patch)
treecf6a3e4d8a28fe814fbc8b425d04e4d4b285dd0e /x11/xcb-util
parent97ea838037646c422e820a1e42d8bcd7157838c3 (diff)
downloadfreebsd-ports-graphics-b2ef5ecad04776d84a13ca59f2b2e1941b395c5b.tar.gz
freebsd-ports-graphics-b2ef5ecad04776d84a13ca59f2b2e1941b395c5b.tar.zst
freebsd-ports-graphics-b2ef5ecad04776d84a13ca59f2b2e1941b395c5b.zip
The xcb-util module provides a number of libraries which sit on top of
libxcb, the core X protocol library, and some of the extension libraries. These experimental libraries provide convenience functions and interfaces which make the raw X protocol more usable. Some of the libraries also provide client-side code which is not strictly part of the X protocol but which have traditionally been provided by Xlib. These libraries are currently included, roughly ordered by maturity: render-util: Convenience functions for the Render extension. aux: Convenient access to connection setup and some core requests. atom: Standard core X atom constants and atom caching. property: Callback X property-change handling. icccm: Both client and window-manager helpers for ICCCM. keysyms: Standard X key constants and conversion to/from keycodes. event: Callback X event handling. image: Port of Xlib's XImage and XShmImage functions. wm: Framework for window manager implementation. WWW: http://xcb.freedesktop.org/ PR: ports/117236 Submitted by: Nikos Ntarmos <ntarmos at ceid.upatras.gr>
Diffstat (limited to 'x11/xcb-util')
-rw-r--r--x11/xcb-util/Makefile34
-rw-r--r--x11/xcb-util/distinfo3
-rw-r--r--x11/xcb-util/pkg-descr20
-rw-r--r--x11/xcb-util/pkg-plist60
4 files changed, 117 insertions, 0 deletions
diff --git a/x11/xcb-util/Makefile b/x11/xcb-util/Makefile
new file mode 100644
index 00000000000..281e74cbd79
--- /dev/null
+++ b/x11/xcb-util/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xcb-util
+# Date created: October 16, 2007
+# Whom: Nikos Ntarmos <ntarmos@ceid.upatras.gr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcb-util
+PORTVERSION= 0.2
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= ntarmos@ceid.upatras.gr
+COMMENT= A module with libxcb/libX11 extension/replacement libraries
+
+LIB_DEPENDS= xcb.1:${PORTSDIR}/x11/libxcb
+BUILD_DEPENDS= gperf:${PORTSDIR}/devel/gperf
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_XORG= xau xdmcp
+USE_XLIB= yes
+USE_AUTOTOOLS= libtool:15
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$${libdir}/pkgconfig|$${prefix}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/x11/xcb-util/distinfo b/x11/xcb-util/distinfo
new file mode 100644
index 00000000000..bfc594951cc
--- /dev/null
+++ b/x11/xcb-util/distinfo
@@ -0,0 +1,3 @@
+MD5 (xcb-util-0.2.tar.bz2) = b09bdebad50638709de22d8eb2dc3bf5
+SHA256 (xcb-util-0.2.tar.bz2) = a0d6a15ac4dcbcea832f2f9b2dbcf575b02cf69aa92f0ba90bd35b61cd75b01a
+SIZE (xcb-util-0.2.tar.bz2) = 255781
diff --git a/x11/xcb-util/pkg-descr b/x11/xcb-util/pkg-descr
new file mode 100644
index 00000000000..827709950ed
--- /dev/null
+++ b/x11/xcb-util/pkg-descr
@@ -0,0 +1,20 @@
+The xcb-util module provides a number of libraries which sit on top of
+libxcb, the core X protocol library, and some of the extension
+libraries. These experimental libraries provide convenience functions
+and interfaces which make the raw X protocol more usable. Some of the
+libraries also provide client-side code which is not strictly part of
+the X protocol but which have traditionally been provided by Xlib.
+
+These libraries are currently included, roughly ordered by maturity:
+
+render-util: Convenience functions for the Render extension.
+aux: Convenient access to connection setup and some core requests.
+atom: Standard core X atom constants and atom caching.
+property: Callback X property-change handling.
+icccm: Both client and window-manager helpers for ICCCM.
+keysyms: Standard X key constants and conversion to/from keycodes.
+event: Callback X event handling.
+image: Port of Xlib's XImage and XShmImage functions.
+wm: Framework for window manager implementation.
+
+WWW: http://xcb.freedesktop.org/
diff --git a/x11/xcb-util/pkg-plist b/x11/xcb-util/pkg-plist
new file mode 100644
index 00000000000..cdd3f7fb63f
--- /dev/null
+++ b/x11/xcb-util/pkg-plist
@@ -0,0 +1,60 @@
+lib/libxcb-atom.so.0
+lib/libxcb-atom.so
+lib/libxcb-atom.la
+lib/libxcb-atom.a
+libdata/pkgconfig/xcb-atom.pc
+libdata/pkgconfig/xcb-aux.pc
+libdata/pkgconfig/xcb-event.pc
+libdata/pkgconfig/xcb-property.pc
+libdata/pkgconfig/xcb-icccm.pc
+libdata/pkgconfig/xcb-image.pc
+libdata/pkgconfig/xcb-keysyms.pc
+libdata/pkgconfig/xcb-reply.pc
+libdata/pkgconfig/xcb-wm.pc
+libdata/pkgconfig/xcb-renderutil.pc
+lib/libxcb-aux.so.0
+lib/libxcb-aux.so
+lib/libxcb-aux.la
+lib/libxcb-aux.a
+lib/libxcb-event.so.0
+lib/libxcb-event.so
+lib/libxcb-event.la
+lib/libxcb-event.a
+lib/libxcb-property.so.0
+lib/libxcb-property.so
+lib/libxcb-property.la
+lib/libxcb-property.a
+lib/libxcb-icccm.so.0
+lib/libxcb-icccm.so
+lib/libxcb-icccm.la
+lib/libxcb-icccm.a
+lib/libxcb-image.so.0
+lib/libxcb-image.so
+lib/libxcb-image.la
+lib/libxcb-image.a
+lib/libxcb-keysyms.so.0
+lib/libxcb-keysyms.so
+lib/libxcb-keysyms.la
+lib/libxcb-keysyms.a
+lib/libxcb-reply.so.0
+lib/libxcb-reply.so
+lib/libxcb-reply.la
+lib/libxcb-reply.a
+lib/libxcb-wm.so.0
+lib/libxcb-wm.so
+lib/libxcb-wm.la
+lib/libxcb-wm.a
+lib/libxcb-render-util.so.0
+lib/libxcb-render-util.so
+lib/libxcb-render-util.la
+lib/libxcb-render-util.a
+include/xcb/xcb_atom.h
+include/xcb/xcb_aux.h
+include/xcb/xcb_event.h
+include/xcb/xcb_property.h
+include/xcb/xcb_icccm.h
+include/xcb/xcb_image.h
+include/xcb/xcb_keysyms.h
+include/xcb/xcb_reply.h
+include/xcb/xcb_wm.h
+include/xcb/xcb_renderutil.h