aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xfce4-clipman-plugin/Makefile
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-03-06 06:52:30 +0800
committerolivierd <olivierd@FreeBSD.org>2015-03-06 06:52:30 +0800
commita8fcb605935f51f7c1487a6b10e2ccbbf792ede1 (patch)
tree0f1a4d58acfbb6944387e341f218a018154dc4ad /x11/xfce4-clipman-plugin/Makefile
parentf79c1de878eea01ceb02aa890c8f1735f64e7070 (diff)
downloadfreebsd-ports-graphics-a8fcb605935f51f7c1487a6b10e2ccbbf792ede1.tar.gz
freebsd-ports-graphics-a8fcb605935f51f7c1487a6b10e2ccbbf792ede1.tar.zst
freebsd-ports-graphics-a8fcb605935f51f7c1487a6b10e2ccbbf792ede1.zip
The FreeBSD Xfce team proudly presents Xfce 4.12.
Announce: http://www.xfce.org/about/news/?post=1425081600 Global changes: - Switch to USES= xfce (D677) - Reorganize options helper - Fix USES= gettext-* when NLS option is not set [1], [2] - Add LICENSE (when missing) Update: - to 4.12 (core components) - audio/xfce4-mpc-plugin to 0.4.5 - deskutils/xfce4-tumbler to 0.1.31 - deskutils/xfce4-xkb-plugin to 0.7.1 - editors/mousepad to 0.4.0 - graphics/ristretto to 0.8.0 - multimedia/xfce4-parole to 0.8.0 - sysutils/garcon to 0.4.0 - sysutils/xfce4-diskperf-plugin to 2.5.5 [3] - sysutils/xfce4-fsguard-plugin to 1.0.2 - sysutils/xfce4-power-manager to 1.4.3 - sysutils/xfce4-wavelan-plugin to 0.5.12 - x11/libexo to 0.10.3 - x11-fm/thunar to 1.6.6 - x11-themes/gtk-xfce-engine to 3.2.0 PR: 196003 [1], 197251 [2], 198132 Differential Revision: https://reviews.freebsd.org/D677 Submitted by: Kamil Szczesny [1], amdmi3@ [2], myself Exp-run by: antoine@ Approved by: danilo@ (maintainer) [3] Tested by: Ivan <enitarzi@gmail.com>
Diffstat (limited to 'x11/xfce4-clipman-plugin/Makefile')
-rw-r--r--x11/xfce4-clipman-plugin/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/x11/xfce4-clipman-plugin/Makefile b/x11/xfce4-clipman-plugin/Makefile
index 368e9edfc3b..387c621968c 100644
--- a/x11/xfce4-clipman-plugin/Makefile
+++ b/x11/xfce4-clipman-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-clipman-plugin
PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -15,30 +15,19 @@ COMMENT= Clipboard manager for the Xfce panel
LICENSE= GPLv2
OPTIONS_DEFINE= QRCODE UNIQUE
+OPTIONS_DEFAULT= UNIQUE
QRCODE_DESC= QR Code support
UNIQUE_DESC= Unique (single instance) support
+QRCODE_LIB_DEPENDS= libqrencode.so:${PORTSDIR}/graphics/libqrencode
+QRCODE_CONFIGURE_ENABLE= libqrencode
+UNIQUE_LIB_DEPENDS= libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
+UNIQUE_CONFIGURE_ENABLE= unique
GNU_CONFIGURE= yes
USE_GNOME= gtk20 intltool intlhack glib20
-USE_XFCE= configenv libexo libmenu libutil panel xfconf
+USE_XFCE= panel
USE_XORG= xtst xproto
-USES= gettext gmake libtool pkgconfig tar:bzip2
+USES= gettext gmake libtool pkgconfig xfce tar:bzip2
INSTALLS_ICONS= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MUNIQUE}
-LIB_DEPENDS+= libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique
-CONFIGURE_ARGS+= --enable-unique
-.else
-CONFIGURE_ARGS+= --disable-unique
-.endif
-
-.if ${PORT_OPTIONS:MQRCODE}
-LIB_DEPENDS+= libqrencode.so:${PORTSDIR}/graphics/libqrencode
-CONFIGURE_ARGS+= --enable-libqrencode
-.else
-CONFIGURE_ARGS+= --disable-libqrencode
-.endif
-
.include <bsd.port.mk>