aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-06-09 03:23:11 +0800
committermarcus <marcus@FreeBSD.org>2008-06-09 03:23:11 +0800
commit2658047d9b5e6e3b38f736bc14b3588e9f79bff7 (patch)
treedc1a9684ca9f142061d63a52654e0b1395df4abe /x11
parenta6e3a0299e2975cf8de15d0d5e9a1e4a1b89b727 (diff)
downloadfreebsd-ports-graphics-2658047d9b5e6e3b38f736bc14b3588e9f79bff7.tar.gz
freebsd-ports-graphics-2658047d9b5e6e3b38f736bc14b3588e9f79bff7.tar.zst
freebsd-ports-graphics-2658047d9b5e6e3b38f736bc14b3588e9f79bff7.zip
Add the ability to spawn seahorse-agent from gdm rather than from every
underlying session. This is very similar to how many Linux distributions integrate seahorse-agent with GNOME. PR: 124398 Submitted by: Robert Noland <rnoland@2hip.net>
Diffstat (limited to 'x11')
-rw-r--r--x11/gdm/Makefile2
-rw-r--r--x11/gdm/files/patch-config_Xsession.in17
2 files changed, 18 insertions, 1 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index e5a23ba91b8..59c799341e8 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gdm
PORTVERSION= 2.20.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/x11/gdm/files/patch-config_Xsession.in b/x11/gdm/files/patch-config_Xsession.in
new file mode 100644
index 00000000000..b97529b0700
--- /dev/null
+++ b/x11/gdm/files/patch-config_Xsession.in
@@ -0,0 +1,17 @@
+--- config/Xsession.in.orig 2008-06-08 09:54:23.000000000 -0400
++++ config/Xsession.in 2008-06-08 09:56:36.000000000 -0400
+@@ -231,6 +231,14 @@
+ fi
+ fi
+
++# add seahorse-agent if found
++seahorseagent="`gdmwhich seahorse-agent`"
++if [ -n "$seahorseagent" ] && [ -x "$seahorseagent" ] && [ -z "$GPG_AGENT_INFO" ] ; then
++ command="$seahorseagent --execute $command"
++elif [ -z "$seahorseagent" ] ; then
++ echo "$0: seahorse-agent not found!"
++fi
++
+ # add ssh-agent if found
+ sshagent="`gdmwhich ssh-agent`"
+ if [ -n "$sshagent" ] && [ -x "$sshagent" ] && [ -z "$SSH_AUTH_SOCK" ]; then