aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-08-16 05:27:24 +0800
committerthierry <thierry@FreeBSD.org>2005-08-16 05:27:24 +0800
commit3ab6bf9b05ca57f4a3d55ceacfee25bb0242b57d (patch)
tree3c1aedca21a3eb7a1a25e85fca833d3d57647566 /x11
parent2e7d5fc5e8f306552b022fe1f7535351cb8eb523 (diff)
downloadfreebsd-ports-graphics-3ab6bf9b05ca57f4a3d55ceacfee25bb0242b57d.tar.gz
freebsd-ports-graphics-3ab6bf9b05ca57f4a3d55ceacfee25bb0242b57d.tar.zst
freebsd-ports-graphics-3ab6bf9b05ca57f4a3d55ceacfee25bb0242b57d.zip
Fix handling of incomplete valid multibyte character sequences.
Bump PORTREVISION. PR: ports/84938 Submitted by: Li-Lun Wang <llwang (at) infor.org> Approved by: portmgr (linimon)
Diffstat (limited to 'x11')
-rw-r--r--x11/rxvt-unicode/Makefile1
-rw-r--r--x11/rxvt-unicode/files/patch-src::command.C14
2 files changed, 12 insertions, 3 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 2b416c2280f..1c9227c8698 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rxvt-unicode
PORTVERSION= 5.7
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/%SUBDIR%/
MASTER_SITE_SUBDIR= . Attic
diff --git a/x11/rxvt-unicode/files/patch-src::command.C b/x11/rxvt-unicode/files/patch-src::command.C
index 471a7a71173..b1ffc5d1d76 100644
--- a/x11/rxvt-unicode/files/patch-src::command.C
+++ b/x11/rxvt-unicode/files/patch-src::command.C
@@ -1,6 +1,14 @@
---- src/command.C.orig Wed Dec 29 20:09:31 2004
-+++ src/command.C Wed Dec 29 22:07:49 2004
-@@ -2716,7 +2716,9 @@
+--- src/command.C.orig Tue Jul 12 22:11:42 2005
++++ src/command.C Mon Aug 15 00:40:13 2005
+@@ -55,6 +55,7 @@
+ #endif
+
+ #include <csignal>
++#include <sys/param.h>
+
+ /*----------------------------------------------------------------------*/
+
+@@ -2716,7 +2717,9 @@
if (len == (size_t)-2)
{
// the mbstate stores incomplete sequences. didn't know this :/