aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2004-04-12 23:49:51 +0800
committerbland <bland@FreeBSD.org>2004-04-12 23:49:51 +0800
commit5c943dd3552b90fe96f400332052ac7e4026b522 (patch)
tree12b05411bdd2415f7d404de81e57b3bc7bea449a /x11
parent818c5418f572f3d7a547a875c7a0ded196f11e1c (diff)
downloadfreebsd-ports-graphics-5c943dd3552b90fe96f400332052ac7e4026b522.tar.gz
freebsd-ports-graphics-5c943dd3552b90fe96f400332052ac7e4026b522.tar.zst
freebsd-ports-graphics-5c943dd3552b90fe96f400332052ac7e4026b522.zip
Fix gdm themes installation. Our chown(8) doesn't likes . as
user/group separator. PR: 65460 Submitted by: ceri
Diffstat (limited to 'x11')
-rw-r--r--x11/gdm2/Makefile2
-rw-r--r--x11/gdm2/files/patch-gui_gdmsetup.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11/gdm2/Makefile b/x11/gdm2/Makefile
index c4f5dddaae5..62ff6ec5f89 100644
--- a/x11/gdm2/Makefile
+++ b/x11/gdm2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdm2
PORTVERSION= 2.6.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
diff --git a/x11/gdm2/files/patch-gui_gdmsetup.c b/x11/gdm2/files/patch-gui_gdmsetup.c
new file mode 100644
index 00000000000..aad93e0baaf
--- /dev/null
+++ b/x11/gdm2/files/patch-gui_gdmsetup.c
@@ -0,0 +1,11 @@
+--- gui/gdmsetup.c.orig Mon Apr 12 14:24:57 2004
++++ gui/gdmsetup.c Mon Apr 12 14:25:00 2004
+@@ -1962,7 +1962,7 @@
+ success = TRUE;
+
+ /* HACK! */
+- cmd = g_strdup_printf ("%s -R root.root %s", chown, quoted);
++ cmd = g_strdup_printf ("%s -R root:wheel %s", chown, quoted);
+ system (cmd);
+ g_free (cmd);
+