aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-03-25 03:11:23 +0800
committermakc <makc@FreeBSD.org>2009-03-25 03:11:23 +0800
commit7b4639d20c13a32165e09360f232cbf52ac84504 (patch)
tree99b1e4f31f9c29a02c1b60dc4aee185328dc5e71 /x11
parent34f4bf1e38b30974641b9f8900fb4e2dffe750d7 (diff)
downloadfreebsd-ports-graphics-7b4639d20c13a32165e09360f232cbf52ac84504.tar.gz
freebsd-ports-graphics-7b4639d20c13a32165e09360f232cbf52ac84504.tar.zst
freebsd-ports-graphics-7b4639d20c13a32165e09360f232cbf52ac84504.zip
Update devel/cmake to 2.6.3.
- Set INSTALL_TARGET for cmake based ports to install/strip. This solves problem of installing non-stripped binaries (noticed by delphij for KDE4 ports) - Fix linking to -lpthread for cmake based ports (KDE4 ports are affected mostly)
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs4/Makefile1
-rw-r--r--x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake15
2 files changed, 13 insertions, 3 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index f5b5d6fb4c5..3b3384f9571 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake b/x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake
index 3c4408efa3b..5a4f9757769 100644
--- a/x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake
+++ b/x11/kdelibs4/files/patch-cmake_modules_FindKDE4Internal.cmake
@@ -1,6 +1,15 @@
---- ../cmake/modules/FindKDE4Internal.cmake.orig 2008-12-04 11:35:54.000000000 +0300
-+++ ../cmake/modules/FindKDE4Internal.cmake 2008-12-15 02:56:07.000000000 +0300
-@@ -743,8 +743,8 @@
+--- ../cmake/modules/FindKDE4Internal.cmake.orig 2009-02-26 17:18:26.000000000 +0300
++++ ../cmake/modules/FindKDE4Internal.cmake 2009-03-22 14:42:53.000000000 +0300
+@@ -550,7 +550,7 @@
+ # whether to install a CMake FooConfig.cmake into lib/foo/cmake/ or /lib/cmake/foo/
+ # (with 2.6.3 and above also lib/cmake/foo/ is supported):
+ if(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION} VERSION_GREATER 2.6.2)
+- option(KDE4_USE_COMMON_CMAKE_PACKAGE_CONFIG_DIR "Prefer to install the <package>Config.cmake files to lib/cmake/<package> instead to lib/<package>/cmake" TRUE)
++ option(KDE4_USE_COMMON_CMAKE_PACKAGE_CONFIG_DIR "Prefer to install the <package>Config.cmake files to lib/cmake/<package> instead to lib/<package>/cmake" FALSE)
+ else(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION} VERSION_GREATER 2.6.2)
+ set(KDE4_USE_COMMON_CMAKE_PACKAGE_CONFIG_DIR FALSE)
+ endif(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION} VERSION_GREATER 2.6.2)
+@@ -694,8 +694,8 @@
_set_fancy(XDG_MIME_INSTALL_DIR "${SHARE_INSTALL_PREFIX}/mime/packages" "The install dir for the xdg mimetypes")
_set_fancy(SYSCONF_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/etc" "The kde sysconfig install dir (default ${CMAKE_INSTALL_PREFIX}/etc)")