aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2013-11-06 04:50:08 +0800
committerthierry <thierry@FreeBSD.org>2013-11-06 04:50:08 +0800
commit828b15033eddc4f6d92a6d4ca845dc507149f001 (patch)
tree68d07810aaa7b1954efc42b79e78ce9aad387aa2 /x11
parentcf755a3d0c2a578c692b68b928d72b231efd62a2 (diff)
downloadfreebsd-ports-graphics-828b15033eddc4f6d92a6d4ca845dc507149f001.tar.gz
freebsd-ports-graphics-828b15033eddc4f6d92a6d4ca845dc507149f001.tar.zst
freebsd-ports-graphics-828b15033eddc4f6d92a6d4ca845dc507149f001.zip
If compiled with clang, rxvt-unicode segfaults when trying to scroll
with the mouse wheel. There are some intrusive patches floating around (from #rxvt-unicode / Cl. Zumbo), but ATM I prefer forcing Gcc. Submitted by: Claudio Zumbo <claudiozumbo (at) gmail <dot> com>
Diffstat (limited to 'x11')
-rw-r--r--x11/rxvt-unicode/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index ec9c05c9cb7..afc3cfdc7b0 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
${LOCALBASE}/share/misc/terminfo.db:${PORTSDIR}/devel/ncurses
USES= pkgconfig shebangfix
+USE_GCC= yes # segfaults when trying to scroll with the mouse wheel if clang
USE_XORG= xpm xft xrender
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include