aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-12-26 03:04:25 +0800
committerantoine <antoine@FreeBSD.org>2014-12-26 03:04:25 +0800
commit8dc323dc2bd29f0219de5776d0c246c80eba274e (patch)
tree1ab8a61c390fb88b46b924e62465cf67b9cc354f /x11
parent25c80782c536ce329491182eaac8df1c164c4f79 (diff)
downloadfreebsd-ports-graphics-8dc323dc2bd29f0219de5776d0c246c80eba274e.tar.gz
freebsd-ports-graphics-8dc323dc2bd29f0219de5776d0c246c80eba274e.tar.zst
freebsd-ports-graphics-8dc323dc2bd29f0219de5776d0c246c80eba274e.zip
Change libpng15.so to libpng.so in LIB_DEPENDS to prepare the upgrade
Diffstat (limited to 'x11')
-rw-r--r--x11/aterm/Makefile2
-rw-r--r--x11/dgs/Makefile2
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kdelibs4/Makefile2
-rw-r--r--x11/mrxvt-devel/Makefile2
-rw-r--r--x11/mrxvt/Makefile2
-rw-r--r--x11/nxcomp/Makefile2
-rw-r--r--x11/slim/Makefile2
-rw-r--r--x11/xautomation/Makefile2
-rw-r--r--x11/xcursorgen/Makefile2
-rw-r--r--x11/xloadimage/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index 07c6205e9bf..4d1041930d8 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -41,7 +41,7 @@ BSDEL_CONFIGURE_OFF= --disable-backspace-key --disable-delete-key
BSDEL_CONFIGURE_ON= --enable-backspace-key --enable-delete-key
MOUSE_CONFIGURE_ENABLE= mousewheel
BGIMG_LIB_DEPENDS= libAfterImage.so:${PORTSDIR}/graphics/libafterimage \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libjpeg.so:${PORTSDIR}/graphics/jpeg
BGIMG_CONFIGURE_ON= --with-afterimage-config --with-png --with-jpeg
BGIMG_CONFIGURE_OFF= --without-afterimage-config --with-png=no --with-jpeg=no
diff --git a/x11/dgs/Makefile b/x11/dgs/Makefile
index c9f141ff1f4..97e2fa8a1bb 100644
--- a/x11/dgs/Makefile
+++ b/x11/dgs/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Display ghostscript system
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
MAKE_JOBS_UNSAFE= yes
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 96e1510d8fd..df20b3df3a4 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libdbusmenu-qt.so:${PORTSDIR}/devel/libdbusmenu-qt \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libfreetype.so:${PORTSDIR}/print/freetype2 \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libxcb-render-util.so:${PORTSDIR}/x11/xcb-util-renderutil \
libxcb-image.so:${PORTSDIR}/x11/xcb-util-image \
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 0fa45e6e6a2..55bd48afc8e 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libavahi-core.so:${PORTSDIR}/net/avahi-app \
libenchant.so:${PORTSDIR}/textproc/enchant \
libgif.so:${PORTSDIR}/graphics/giflib \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libhal.so:${PORTSDIR}/sysutils/hal \
libqca.so:${PORTSDIR}/devel/qca \
diff --git a/x11/mrxvt-devel/Makefile b/x11/mrxvt-devel/Makefile
index c6d28b0263a..1e88bd744f7 100644
--- a/x11/mrxvt-devel/Makefile
+++ b/x11/mrxvt-devel/Makefile
@@ -75,7 +75,7 @@ LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
.if ! ${PORT_OPTIONS:MPNG} || ! ${PORT_OPTIONS:MBACKGROUND}
CONFIGURE_ARGS+= --disable-png
.else
-LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png
.endif
.if ! ${PORT_OPTIONS:MTRANSPARENCY}
diff --git a/x11/mrxvt/Makefile b/x11/mrxvt/Makefile
index 7bc0dd3b66a..9ee21de126c 100644
--- a/x11/mrxvt/Makefile
+++ b/x11/mrxvt/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Tabbed version of rxvt
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png
+ libpng.so:${PORTSDIR}/graphics/png
CONFLICTS= mrxvt-0.5.*
diff --git a/x11/nxcomp/Makefile b/x11/nxcomp/Makefile
index e74033366e0..ef5565076ee 100644
--- a/x11/nxcomp/Makefile
+++ b/x11/nxcomp/Makefile
@@ -15,7 +15,7 @@ USE_AUTOTOOLS= autoconf
USE_XORG= xproto
GNU_CONFIGURE= yes
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png
+ libpng.so:${PORTSDIR}/graphics/png
post-patch:
@${REINPLACE_CMD} -e "s,libdir}/nx,libdir},g" ${WRKSRC}/Makefile.in
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index b1c3e27927e..7ccb7b6dcbd 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libck-connector.so:${PORTSDIR}/sysutils/consolekit \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
diff --git a/x11/xautomation/Makefile b/x11/xautomation/Makefile
index 426ca87c4df..7d646e0cc0d 100644
--- a/x11/xautomation/Makefile
+++ b/x11/xautomation/Makefile
@@ -11,7 +11,7 @@ COMMENT= Control X from the command line for scripts
LICENSE= GPLv2
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
USE_XORG= xtst
GNU_CONFIGURE= yes
diff --git a/x11/xcursorgen/Makefile b/x11/xcursorgen/Makefile
index 5cd167b37c8..046268b6b45 100644
--- a/x11/xcursorgen/Makefile
+++ b/x11/xcursorgen/Makefile
@@ -9,7 +9,7 @@ COMMENT= Create an X cursor file from a collection of PNG images
LICENSE= MIT
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
XORG_CAT= app
USE_XORG= x11 xcursor xextproto
diff --git a/x11/xloadimage/Makefile b/x11/xloadimage/Makefile
index 4f24c6e8249..7a738a58c91 100644
--- a/x11/xloadimage/Makefile
+++ b/x11/xloadimage/Makefile
@@ -15,7 +15,7 @@ COMMENT= X11 Image Loading Utility
LICENSE= MIT
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
CONFLICTS_INSTALL= xli-*