aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-01-16 01:17:32 +0800
committerkwm <kwm@FreeBSD.org>2015-01-16 01:17:32 +0800
commitbac8d6db0782d29638beddd2225027e655086479 (patch)
tree6e007753da8b091875b5ab908112433ebaca71fe /x11
parent392b519e1976500bdbe6d5b6bd431a7a94c015dc (diff)
downloadfreebsd-ports-graphics-bac8d6db0782d29638beddd2225027e655086479.tar.gz
freebsd-ports-graphics-bac8d6db0782d29638beddd2225027e655086479.tar.zst
freebsd-ports-graphics-bac8d6db0782d29638beddd2225027e655086479.zip
Sprinkle some PORTSCOUT macros around to either mark ports:
* ignore because there will not be any new releases. * check specific versions or ignore devel versions.
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-desktop/Makefile2
-rw-r--r--x11/gnome-session/Makefile2
-rw-r--r--x11/gnome-shell-extensions/Makefile2
-rw-r--r--x11/gnome-shell/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/x11/gnome-desktop/Makefile b/x11/gnome-desktop/Makefile
index f9f4fb526a5..39546f96db5 100644
--- a/x11/gnome-desktop/Makefile
+++ b/x11/gnome-desktop/Makefile
@@ -14,6 +14,8 @@ COMMENT= Additional UI API for GNOME 3
USES= tar:xz
+PORTSCOUT= limitw:1,even
+
.if !defined(REFERENCE_PORT)
BUILD_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes \
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
index 3cb30b8c671..22c85814b04 100644
--- a/x11/gnome-session/Makefile
+++ b/x11/gnome-session/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
RUN_DEPENDS= ${LOCALBASE}/sbin/console-kit-daemon:${PORTSDIR}/sysutils/consolekit \
${LOCALBASE}/bin/xdpyinfo:${PORTSDIR}/x11/xdpyinfo
+PORTSCOUT= limitw:1,even
+
USES= execinfo gettext gmake pathfix pkgconfig tar:xz
USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack intlhack \
libxslt:build
diff --git a/x11/gnome-shell-extensions/Makefile b/x11/gnome-shell-extensions/Makefile
index dba0c6a506a..1214496de47 100644
--- a/x11/gnome-shell-extensions/Makefile
+++ b/x11/gnome-shell-extensions/Makefile
@@ -14,6 +14,8 @@ COMMENT= GNOME desktop shell extensions
LIB_DEPENDS= libgtop-2.0.so:${PORTSDIR}/devel/libgtop
RUN_DEPENDS= gnome-shell>=3.12.0:${PORTSDIR}/x11/gnome-shell
+PORTSCOUT= limitw:1,even
+
USES= gettext gmake pathfix pkgconfig tar:xz
USE_GNOME= glib20 gnomedesktop3 intlhack
USE_LDCONFIG= yes
diff --git a/x11/gnome-shell/Makefile b/x11/gnome-shell/Makefile
index 74052afcfbc..78e640f3939 100644
--- a/x11/gnome-shell/Makefile
+++ b/x11/gnome-shell/Makefile
@@ -32,6 +32,8 @@ RUN_DEPENDS= py*-dbus>=0:${PORTSDIR}/devel/py-dbus \
gnome-control-center:${PORTSDIR}/sysutils/gnome-control-center \
ca_root_nss>=0:${PORTSDIR}/security/ca_root_nss
+PORTSCOUT= limitw:1,even
+
USES= compiler:c11 gettext gmake libtool pathfix pkgconfig \
tar:xz webplugin:native
USE_GNOME= evolutiondataserver3 gnomedesktop3 gnomeprefix \