aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-09-02 20:05:58 +0800
committerzeising <zeising@FreeBSD.org>2013-09-02 20:05:58 +0800
commitd0c3650e782e67611c1816ce52a927df1f7453c4 (patch)
treeba36522c455be229dd8331b1ec4c334d2142d1b2 /x11
parent78f1a4fa65c71448224a82e5e944a4929e1955ec (diff)
downloadfreebsd-ports-graphics-d0c3650e782e67611c1816ce52a927df1f7453c4.tar.gz
freebsd-ports-graphics-d0c3650e782e67611c1816ce52a927df1f7453c4.tar.zst
freebsd-ports-graphics-d0c3650e782e67611c1816ce52a927df1f7453c4.zip
A bunch of cleanups and fixes.
Fix build with compiler is gccXX (where xx is for instance 46, 47) by running autoconf to generate a working configure. Use ${REINPLACE_CMD} instead of hand-rolled sed. Change regexp to work on configure.in instead of configure, since we'll autoconf configure.in anyway. Check for libutil.h alongside util.h, and make use of that if it is found. Make detection and use of gettext work with all compilers. Add locale messages to plist. Bump portrevision. Noticed by: avg (build issues) Tested by: avg
Diffstat (limited to 'x11')
-rw-r--r--x11/xscreensaver/Makefile13
-rw-r--r--x11/xscreensaver/files/patch-config.h.in12
-rw-r--r--x11/xscreensaver/files/patch-configure.in11
-rw-r--r--x11/xscreensaver/files/patch-driver_Makefile.in13
-rw-r--r--x11/xscreensaver/files/patch-utils_textclient.c12
-rw-r--r--x11/xscreensaver/pkg-plist68
6 files changed, 120 insertions, 9 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 47c0bbd29f8..7acd8014b66 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xscreensaver
PORTVERSION= 5.22
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/
@@ -26,6 +26,8 @@ USES= pkgconfig gettext gmake
USE_XORG= xpm xext xxf86misc
USE_GL= yes
GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf
+CONFIGURE_ENV+= "CPPFLAGS= -I ${LOCALBASE}/include" "LDFLAGS= -L ${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-gtk --with-gl --with-gle --with-pixbuf --with-xpm \
--with-jpeg=${LOCALBASE} --with-xshm-ext --with-xdbe-ext \
--with-hackdir=${PREFIX}/bin/xscreensaver-hacks/ \
@@ -132,12 +134,9 @@ SUB_FILES= xscreensaver-blank.desktop xscreensaver-lock.desktop \
xscreensaver-start.desktop xscreensaver-stop.desktop
post-patch:
- @ ${CP} ${WRKSRC}/configure ${WRKSRC}/configure.Patched
- @ ${SED} -e 's#-lpthread#${PTHREAD_LIBS}#g' \
- -e 's#malloc.h#stdlib.h#g' \
- -e 's#/usr/X11R6#${LOCALBASE}#g' \
- -e 's#pkg_config --list-all#pkg_config --help#' \
- ${WRKSRC}/configure.Patched > ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' \
+ -e 's|pkg_config --list-all|pkg_config --help|' \
+ ${WRKSRC}/configure.in
.if ${PORT_OPTIONS:MPAM}
.for f in driver/passwd-pam.c driver/xscreensaver.man
@ ${CP} ${WRKSRC}/${f} ${WRKSRC}/${f}.presed
diff --git a/x11/xscreensaver/files/patch-config.h.in b/x11/xscreensaver/files/patch-config.h.in
new file mode 100644
index 00000000000..1d1561653ce
--- /dev/null
+++ b/x11/xscreensaver/files/patch-config.h.in
@@ -0,0 +1,12 @@
+--- config.h.in.orig 2013-09-02 12:44:35.341733572 +0200
++++ config.h.in 2013-09-02 12:45:05.396737361 +0200
+@@ -340,6 +340,9 @@
+ /* Define to 1 if you have the <util.h> header file. */
+ #undef HAVE_UTIL_H
+
++/* Define to 1 if you have the <libutil.h> header file. */
++#undef HAVE_LIBUTIL_H
++
+ /* Define this if you have the XF86MiscSetGrabKeysState function (which allows
+ the Ctrl-Alt-KP_star and Ctrl-Alt-KP_slash key sequences to be temporarily
+ disabled. Sadly, it doesn't affect Ctrl-Alt-BS or Ctrl-Alt-F1.) */
diff --git a/x11/xscreensaver/files/patch-configure.in b/x11/xscreensaver/files/patch-configure.in
new file mode 100644
index 00000000000..e56bcded955
--- /dev/null
+++ b/x11/xscreensaver/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig 2013-09-02 12:45:33.940731237 +0200
++++ configure.in 2013-09-02 12:46:13.253728009 +0200
+@@ -3359,7 +3359,7 @@
+ ###############################################################################
+
+ PTY_LIBS=
+-AC_CHECK_HEADERS(pty.h util.h)
++AC_CHECK_HEADERS(pty.h util.h libutil.h)
+ AC_CHECK_X_LIB(util, forkpty,
+ [PTY_LIBS="-lutil"
+ ac_have_forkpty=yes
diff --git a/x11/xscreensaver/files/patch-driver_Makefile.in b/x11/xscreensaver/files/patch-driver_Makefile.in
index e195bfec35f..54c8757b005 100644
--- a/x11/xscreensaver/files/patch-driver_Makefile.in
+++ b/x11/xscreensaver/files/patch-driver_Makefile.in
@@ -1,5 +1,5 @@
---- driver/Makefile.in.orig 2008-07-16 14:40:49.000000000 -0700
-+++ driver/Makefile.in 2008-07-18 16:23:37.000000000 -0700
+--- driver/Makefile.in.orig 2013-07-16 11:23:32.000000000 +0200
++++ driver/Makefile.in 2013-09-02 11:56:16.862939343 +0200
@@ -81,8 +81,8 @@
@@ -11,3 +11,12 @@
UTILS_SRC = $(srcdir)/../utils
UTILS_BIN = ../utils
+@@ -207,7 +207,7 @@
+ SAVER_LIBS = $(LIBS) $(X_LIBS) $(XMU_LIBS) @SAVER_LIBS@ \
+ $(XDPMS_LIBS) $(XINERAMA_LIBS) $(GL_LIBS) $(X_PRE_LIBS) \
+ -lXt -lX11 -lXext $(X_EXTRA_LIBS) \
+- $(PASSWD_LIBS)
++ $(PASSWD_LIBS) $(INTL_LIBS)
+
+ CMD_LIBS = $(LIBS) $(X_LIBS) \
+ $(X_PRE_LIBS) -lX11 -lXext $(X_EXTRA_LIBS)
diff --git a/x11/xscreensaver/files/patch-utils_textclient.c b/x11/xscreensaver/files/patch-utils_textclient.c
new file mode 100644
index 00000000000..b46d2ffc9ae
--- /dev/null
+++ b/x11/xscreensaver/files/patch-utils_textclient.c
@@ -0,0 +1,12 @@
+--- utils/textclient.c.orig 2013-09-02 12:43:01.271738814 +0200
++++ utils/textclient.c 2013-09-02 12:43:25.014748042 +0200
+@@ -50,6 +50,9 @@
+ # ifdef HAVE_UTIL_H
+ # include <util.h>
+ # endif
++# ifdef HAVE_LIBUTIL_H
++# include <libutil.h>
++# endif
+ #endif /* HAVE_FORKPTY */
+
+ /*#define DEBUG*/
diff --git a/x11/xscreensaver/pkg-plist b/x11/xscreensaver/pkg-plist
index 74a8c90f942..e9cb5dd82ee 100644
--- a/x11/xscreensaver/pkg-plist
+++ b/x11/xscreensaver/pkg-plist
@@ -217,6 +217,29 @@ share/applications/xscreensaver-lock.desktop
share/applications/xscreensaver-properties.desktop
share/applications/xscreensaver-start.desktop
share/applications/xscreensaver-stop.desktop
+share/locale/ca/LC_MESSAGES/xscreensaver.mo
+share/locale/da/LC_MESSAGES/xscreensaver.mo
+share/locale/de/LC_MESSAGES/xscreensaver.mo
+share/locale/es/LC_MESSAGES/xscreensaver.mo
+share/locale/et/LC_MESSAGES/xscreensaver.mo
+share/locale/fi/LC_MESSAGES/xscreensaver.mo
+share/locale/fr/LC_MESSAGES/xscreensaver.mo
+share/locale/hu/LC_MESSAGES/xscreensaver.mo
+share/locale/it/LC_MESSAGES/xscreensaver.mo
+share/locale/ja/LC_MESSAGES/xscreensaver.mo
+share/locale/ko/LC_MESSAGES/xscreensaver.mo
+share/locale/nb/LC_MESSAGES/xscreensaver.mo
+share/locale/nl/LC_MESSAGES/xscreensaver.mo
+share/locale/pl/LC_MESSAGES/xscreensaver.mo
+share/locale/pt/LC_MESSAGES/xscreensaver.mo
+share/locale/pt_BR/LC_MESSAGES/xscreensaver.mo
+share/locale/ru/LC_MESSAGES/xscreensaver.mo
+share/locale/sk/LC_MESSAGES/xscreensaver.mo
+share/locale/sv/LC_MESSAGES/xscreensaver.mo
+share/locale/vi/LC_MESSAGES/xscreensaver.mo
+share/locale/wa/LC_MESSAGES/xscreensaver.mo
+share/locale/zh_CN/LC_MESSAGES/xscreensaver.mo
+share/locale/zh_TW/LC_MESSAGES/xscreensaver.mo
share/pixmaps/xscreensaver.xpm
%%DATADIR%%/config/README
%%DATADIR%%/config/abstractile.xml
@@ -436,6 +459,51 @@ share/pixmaps/xscreensaver.xpm
%%DATADIR%%/glade/screensaver-snap.png
%%DATADIR%%/glade/xscreensaver-demo.glade2
@dirrmtry bin/xscreensaver-hacks
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/da/LC_MESSAGES
+@dirrmtry share/locale/da
+@dirrmtry share/locale/de/LC_MESSAGES
+@dirrmtry share/locale/de
+@dirrmtry share/locale/es/LC_MESSAGES
+@dirrmtry share/locale/es
+@dirrmtry share/locale/et/LC_MESSAGES
+@dirrmtry share/locale/et
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/fr/LC_MESSAGES
+@dirrmtry share/locale/fr
+@dirrmtry share/locale/hu/LC_MESSAGES
+@dirrmtry share/locale/hu
+@dirrmtry share/locale/it/LC_MESSAGES
+@dirrmtry share/locale/it
+@dirrmtry share/locale/ja/LC_MESSAGES
+@dirrmtry share/locale/ja
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/nb/LC_MESSAGES
+@dirrmtry share/locale/nb
+@dirrmtry share/locale/nl/LC_MESSAGES
+@dirrmtry share/locale/nl
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pt_BR/LC_MESSAGES
+@dirrmtry share/locale/pt_BR
+@dirrmtry share/locale/ru/LC_MESSAGES
+@dirrmtry share/locale/ru
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/sv/LC_MESSAGES
+@dirrmtry share/locale/sv
+@dirrmtry share/locale/vi/LC_MESSAGES
+@dirrmtry share/locale/vi
+@dirrmtry share/locale/wa/LC_MESSAGES
+@dirrmtry share/locale/wa
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale
@dirrmtry share/applications
@dirrmtry %%DATADIR%%/config
@dirrm %%DATADIR%%/glade