aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1995-04-26 22:45:15 +0800
committerjmz <jmz@FreeBSD.org>1995-04-26 22:45:15 +0800
commitf598068011d67f2ad5e710deb6078905df8b3ae5 (patch)
tree2177ff07010570c88b82d0e09f035ede0f07dcb7 /x11
parent77f94ce087d5b71bd7c676c8a4de26b33101d932 (diff)
downloadfreebsd-ports-graphics-f598068011d67f2ad5e710deb6078905df8b3ae5.tar.gz
freebsd-ports-graphics-f598068011d67f2ad5e710deb6078905df8b3ae5.tar.zst
freebsd-ports-graphics-f598068011d67f2ad5e710deb6078905df8b3ae5.zip
Use 'do-install:' instead of 'install:'
Complain and fail if no build option is set.
Diffstat (limited to 'x11')
-rw-r--r--x11/XFree86-4-clients/Makefile14
-rw-r--r--x11/XFree86-4-libraries/Makefile14
-rw-r--r--x11/XFree86-4/Makefile14
-rw-r--r--x11/XFree86/Makefile14
4 files changed, 32 insertions, 24 deletions
diff --git a/x11/XFree86-4-clients/Makefile b/x11/XFree86-4-clients/Makefile
index 7ba86196c06..9b1e60f5401 100644
--- a/x11/XFree86-4-clients/Makefile
+++ b/x11/XFree86-4-clients/Makefile
@@ -3,7 +3,7 @@
# Date created: 5 January 1995
# Whom: jmz
#
-# $Id: Makefile,v 1.6 1995/04/13 15:22:11 jmz Exp $
+# $Id: Makefile,v 1.7 1995/04/22 22:39:30 jmz Exp $
#
#######################################################################
@@ -46,7 +46,7 @@ do-build:
@(cd ${WRKSRC}; echo Good night...; make World)
@touch ${WRKDIR}/.build_done
-install:
+do-install:
@(cd ${WRKSRC}; make install; make install.man)
@touch ${WRKDIR}/.install_done
.if defined(X11_ON_CDROM)
@@ -77,16 +77,18 @@ do-extract:
.elif defined(X11_VIA_FTP)
.include "Makefile.ftp"
.else
-all:
- @echo -n
do-fetch:
- @echo -n
+ @echo Please set one of the 3 variables X11_ON_X_CDROM, X11_ON_OR_CDROM, or X11_VIA_FTP
+ @echo before building ${PKGNAME}
+ @false
do-extract:
@echo -n
do-configure:
@echo -n
do-build:
- @echo -n
+ @echo Please set one of the 3 variables X11_ON_X_CDROM, X11_ON_OR_CDROM, or X11_VIA_FTP
+ @echo before building ${PKGNAME}
+ @false
do-install:
@echo -n
.endif
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index 7ba86196c06..9b1e60f5401 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -3,7 +3,7 @@
# Date created: 5 January 1995
# Whom: jmz
#
-# $Id: Makefile,v 1.6 1995/04/13 15:22:11 jmz Exp $
+# $Id: Makefile,v 1.7 1995/04/22 22:39:30 jmz Exp $
#
#######################################################################
@@ -46,7 +46,7 @@ do-build:
@(cd ${WRKSRC}; echo Good night...; make World)
@touch ${WRKDIR}/.build_done
-install:
+do-install:
@(cd ${WRKSRC}; make install; make install.man)
@touch ${WRKDIR}/.install_done
.if defined(X11_ON_CDROM)
@@ -77,16 +77,18 @@ do-extract:
.elif defined(X11_VIA_FTP)
.include "Makefile.ftp"
.else
-all:
- @echo -n
do-fetch:
- @echo -n
+ @echo Please set one of the 3 variables X11_ON_X_CDROM, X11_ON_OR_CDROM, or X11_VIA_FTP
+ @echo before building ${PKGNAME}
+ @false
do-extract:
@echo -n
do-configure:
@echo -n
do-build:
- @echo -n
+ @echo Please set one of the 3 variables X11_ON_X_CDROM, X11_ON_OR_CDROM, or X11_VIA_FTP
+ @echo before building ${PKGNAME}
+ @false
do-install:
@echo -n
.endif
diff --git a/x11/XFree86-4/Makefile b/x11/XFree86-4/Makefile
index 7ba86196c06..9b1e60f5401 100644
--- a/x11/XFree86-4/Makefile
+++ b/x11/XFree86-4/Makefile
@@ -3,7 +3,7 @@
# Date created: 5 January 1995
# Whom: jmz
#
-# $Id: Makefile,v 1.6 1995/04/13 15:22:11 jmz Exp $
+# $Id: Makefile,v 1.7 1995/04/22 22:39:30 jmz Exp $
#
#######################################################################
@@ -46,7 +46,7 @@ do-build:
@(cd ${WRKSRC}; echo Good night...; make World)
@touch ${WRKDIR}/.build_done
-install:
+do-install:
@(cd ${WRKSRC}; make install; make install.man)
@touch ${WRKDIR}/.install_done
.if defined(X11_ON_CDROM)
@@ -77,16 +77,18 @@ do-extract:
.elif defined(X11_VIA_FTP)
.include "Makefile.ftp"
.else
-all:
- @echo -n
do-fetch:
- @echo -n
+ @echo Please set one of the 3 variables X11_ON_X_CDROM, X11_ON_OR_CDROM, or X11_VIA_FTP
+ @echo before building ${PKGNAME}
+ @false
do-extract:
@echo -n
do-configure:
@echo -n
do-build:
- @echo -n
+ @echo Please set one of the 3 variables X11_ON_X_CDROM, X11_ON_OR_CDROM, or X11_VIA_FTP
+ @echo before building ${PKGNAME}
+ @false
do-install:
@echo -n
.endif
diff --git a/x11/XFree86/Makefile b/x11/XFree86/Makefile
index 7ba86196c06..9b1e60f5401 100644
--- a/x11/XFree86/Makefile
+++ b/x11/XFree86/Makefile
@@ -3,7 +3,7 @@
# Date created: 5 January 1995
# Whom: jmz
#
-# $Id: Makefile,v 1.6 1995/04/13 15:22:11 jmz Exp $
+# $Id: Makefile,v 1.7 1995/04/22 22:39:30 jmz Exp $
#
#######################################################################
@@ -46,7 +46,7 @@ do-build:
@(cd ${WRKSRC}; echo Good night...; make World)
@touch ${WRKDIR}/.build_done
-install:
+do-install:
@(cd ${WRKSRC}; make install; make install.man)
@touch ${WRKDIR}/.install_done
.if defined(X11_ON_CDROM)
@@ -77,16 +77,18 @@ do-extract:
.elif defined(X11_VIA_FTP)
.include "Makefile.ftp"
.else
-all:
- @echo -n
do-fetch:
- @echo -n
+ @echo Please set one of the 3 variables X11_ON_X_CDROM, X11_ON_OR_CDROM, or X11_VIA_FTP
+ @echo before building ${PKGNAME}
+ @false
do-extract:
@echo -n
do-configure:
@echo -n
do-build:
- @echo -n
+ @echo Please set one of the 3 variables X11_ON_X_CDROM, X11_ON_OR_CDROM, or X11_VIA_FTP
+ @echo before building ${PKGNAME}
+ @false
do-install:
@echo -n
.endif