aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2012-04-11 04:26:24 +0800
committercy <cy@FreeBSD.org>2012-04-11 04:26:24 +0800
commitfc6136972a6ec5490c130e57ff7f9261efa87282 (patch)
treeafc8d03c44955a9d3be8c4b241d61a591dd1f8f9 /x11
parentf20f84c81f2978662afb0af257614db9580b3ad7 (diff)
downloadfreebsd-ports-graphics-fc6136972a6ec5490c130e57ff7f9261efa87282.tar.gz
freebsd-ports-graphics-fc6136972a6ec5490c130e57ff7f9261efa87282.tar.zst
freebsd-ports-graphics-fc6136972a6ec5490c130e57ff7f9261efa87282.zip
Welcome xascii to ports. Xascii has been around for a long time. It displays
the complete ascii character set along with each character's value in either decimal, hexidecimal, or octal notation.
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xascii/Makefile25
-rw-r--r--x11/xascii/distinfo2
-rw-r--r--x11/xascii/files/patch-Imakefile11
-rw-r--r--x11/xascii/files/patch-xascii.c12
-rw-r--r--x11/xascii/pkg-descr2
6 files changed, 53 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index dc02daba156..6043a0d55e8 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -303,6 +303,7 @@
SUBDIR += x3270
SUBDIR += xaniroc
SUBDIR += xantfarm
+ SUBDIR += xascii
SUBDIR += xauth
SUBDIR += xautolock
SUBDIR += xautomation
diff --git a/x11/xascii/Makefile b/x11/xascii/Makefile
new file mode 100644
index 00000000000..a607ab43db4
--- /dev/null
+++ b/x11/xascii/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xascii
+# Date created: 10 April 2012
+# Whom: Cy Schubert <cy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xascii
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= http://komquats.com/distfiles/ \
+ http://people.freebsd.org/~cy/distfiles/
+
+WRKSRC= ${WRKDIR}
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Manipulate X cut buffers from the commandline
+
+MAKE_ARGS+= PREFIX=${PREFIX}
+USE_IMAKE= YES
+USE_XORG= x11
+MAN1= xascii.1
+PLIST_FILES= bin/xascii
+
+.include <bsd.port.mk>
diff --git a/x11/xascii/distinfo b/x11/xascii/distinfo
new file mode 100644
index 00000000000..f384d2121b7
--- /dev/null
+++ b/x11/xascii/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xascii-1.0.tar.gz) = ff0c48a251f84dc186e123849dacd151d47aff7bd4bb4bfd955b6f67dd9b0de5
+SIZE (xascii-1.0.tar.gz) = 7090
diff --git a/x11/xascii/files/patch-Imakefile b/x11/xascii/files/patch-Imakefile
new file mode 100644
index 00000000000..0fa99debeb9
--- /dev/null
+++ b/x11/xascii/files/patch-Imakefile
@@ -0,0 +1,11 @@
+--- Imakefile.orig 1991-08-05 12:32:29.000000000 -0700
++++ Imakefile 2012-04-10 12:55:45.138341509 -0700
+@@ -1,5 +1,8 @@
+ LOCAL_LIBRARIES = XawClientLibs
+
++BINDIR = ${PREFIX}/bin
++MANPATH = ${PREFIX}${MAN1PREFIX}/man
++
+ SRCS = xascii.c
+ OBJS = xascii.o
+
diff --git a/x11/xascii/files/patch-xascii.c b/x11/xascii/files/patch-xascii.c
new file mode 100644
index 00000000000..f7dc6796fad
--- /dev/null
+++ b/x11/xascii/files/patch-xascii.c
@@ -0,0 +1,12 @@
+--- xascii.c.orig 1991-08-05 13:57:57.000000000 -0700
++++ xascii.c 2010-10-13 16:14:45.388101391 -0700
+@@ -454,8 +454,7 @@
+ XtTranslateCoords (toplevel,
+ (Position) 0,
+ (Position) height/2,
+- &x, &y,
+- NULL);
++ &x, &y);
+
+ XtVaSetValues (pshell,
+ XtNx, x,
diff --git a/x11/xascii/pkg-descr b/x11/xascii/pkg-descr
new file mode 100644
index 00000000000..9626613de16
--- /dev/null
+++ b/x11/xascii/pkg-descr
@@ -0,0 +1,2 @@
+Xascii displays the complete ascii character set along with each character's
+value in either decimal, hexidecimal, or octal notation.