aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/gxine/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
index d023a0d0df4..52b203126cc 100644
--- a/multimedia/gxine/Makefile
+++ b/multimedia/gxine/Makefile
@@ -68,15 +68,12 @@ PLIST_SUB+= MOZILLA_PLUGIN="@comment "
USE_GECKO= firefox mozilla xulrunner firefox15
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
LIB_DEPENDS+= nspr4.1:${PORTSDIR}/devel/nspr
+CONFIGURE_ENV+= NSPR_CFLAGS="-I${LOCALBASE}/include/nspr" \
+ NSPR_LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--disable-libjs
-CFLAGS+= -I${LOCALBASE}/include/nspr
PLIST_SUB+= MOZILLA_PLUGIN=""
.endif
-post-patch:
- @${REINPLACE_CMD} -e "s|firefox/nspr/||g" \
- ${WRKSRC}/configure
-
post-install:
.if !defined(WITHOUT_MOZILLA_PLUGIN)
@${MKDIR} ${PREFIX}/lib/browser_plugins