aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/gaim-hotkeys/Makefile32
-rw-r--r--net-im/gaim-hotkeys/distinfo3
-rw-r--r--net-im/gaim-hotkeys/pkg-descr6
-rw-r--r--net-im/pidgin-hotkeys/Makefile32
-rw-r--r--net-im/pidgin-hotkeys/distinfo3
-rw-r--r--net-im/pidgin-hotkeys/pkg-descr6
7 files changed, 83 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index bb27e1e9400..ec6bc4f84fb 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -27,6 +27,7 @@
SUBDIR += gaim-devel
SUBDIR += gaim-extprefs
SUBDIR += gaim-guifications
+ SUBDIR += gaim-hotkeys
SUBDIR += gaim-ignorance
SUBDIR += gaim-latex
SUBDIR += gaim-openq
diff --git a/net-im/gaim-hotkeys/Makefile b/net-im/gaim-hotkeys/Makefile
new file mode 100644
index 00000000000..6148938a0ca
--- /dev/null
+++ b/net-im/gaim-hotkeys/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gaim-hotkeys
+# Date created: 2006-11-23
+# Whom: garga
+#
+# $FreeBSD$
+#
+
+PORTNAME= gaim-hotkeys
+PORTVERSION= 0.2.2
+CATEGORIES= net-im
+MASTER_SITES= SF
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= A gaim plugin that allows user to assign global hotkeys
+
+LIB_DEPENDS= gaim.0:${PORTSDIR}/net-im/libgaim
+BUILD_DEPENDS= gaim:${PORTSDIR}/net-im/gaim-devel
+RUN_DEPENDS= gaim:${PORTSDIR}/net-im/gaim-devel
+
+USE_GNOME= pkgconfig gtk20
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/gaim/hotkeys.so \
+ lib/gaim/hotkeys.la
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= net-im/libgaim doesn't build on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/gaim-hotkeys/distinfo b/net-im/gaim-hotkeys/distinfo
new file mode 100644
index 00000000000..70111249862
--- /dev/null
+++ b/net-im/gaim-hotkeys/distinfo
@@ -0,0 +1,3 @@
+MD5 (gaim-hotkeys-0.2.2.tar.gz) = 9c413e3e1a4a56f004792794a277cae0
+SHA256 (gaim-hotkeys-0.2.2.tar.gz) = 2004a89f45af5fc8eb01c53a3def935a59e9ee296bafe26e755fb4bcecda6239
+SIZE (gaim-hotkeys-0.2.2.tar.gz) = 341544
diff --git a/net-im/gaim-hotkeys/pkg-descr b/net-im/gaim-hotkeys/pkg-descr
new file mode 100644
index 00000000000..119404f8aaa
--- /dev/null
+++ b/net-im/gaim-hotkeys/pkg-descr
@@ -0,0 +1,6 @@
+A gaim plugin that allows user to assign global hotkeys (e.g. Ctrl+Alt+g) for
+togglling buddy list and reading queued message. When "Toggle List" hotkey is
+enabled, it makes the buddy list hidden from your taskbar and task switcher
+(similar to ICQ).
+
+WWW: http://sourceforge.net/projects/gaim-hotkeys/
diff --git a/net-im/pidgin-hotkeys/Makefile b/net-im/pidgin-hotkeys/Makefile
new file mode 100644
index 00000000000..6148938a0ca
--- /dev/null
+++ b/net-im/pidgin-hotkeys/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gaim-hotkeys
+# Date created: 2006-11-23
+# Whom: garga
+#
+# $FreeBSD$
+#
+
+PORTNAME= gaim-hotkeys
+PORTVERSION= 0.2.2
+CATEGORIES= net-im
+MASTER_SITES= SF
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= A gaim plugin that allows user to assign global hotkeys
+
+LIB_DEPENDS= gaim.0:${PORTSDIR}/net-im/libgaim
+BUILD_DEPENDS= gaim:${PORTSDIR}/net-im/gaim-devel
+RUN_DEPENDS= gaim:${PORTSDIR}/net-im/gaim-devel
+
+USE_GNOME= pkgconfig gtk20
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/gaim/hotkeys.so \
+ lib/gaim/hotkeys.la
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= net-im/libgaim doesn't build on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/pidgin-hotkeys/distinfo b/net-im/pidgin-hotkeys/distinfo
new file mode 100644
index 00000000000..70111249862
--- /dev/null
+++ b/net-im/pidgin-hotkeys/distinfo
@@ -0,0 +1,3 @@
+MD5 (gaim-hotkeys-0.2.2.tar.gz) = 9c413e3e1a4a56f004792794a277cae0
+SHA256 (gaim-hotkeys-0.2.2.tar.gz) = 2004a89f45af5fc8eb01c53a3def935a59e9ee296bafe26e755fb4bcecda6239
+SIZE (gaim-hotkeys-0.2.2.tar.gz) = 341544
diff --git a/net-im/pidgin-hotkeys/pkg-descr b/net-im/pidgin-hotkeys/pkg-descr
new file mode 100644
index 00000000000..119404f8aaa
--- /dev/null
+++ b/net-im/pidgin-hotkeys/pkg-descr
@@ -0,0 +1,6 @@
+A gaim plugin that allows user to assign global hotkeys (e.g. Ctrl+Alt+g) for
+togglling buddy list and reading queued message. When "Toggle List" hotkey is
+enabled, it makes the buddy list hidden from your taskbar and task switcher
+(similar to ICQ).
+
+WWW: http://sourceforge.net/projects/gaim-hotkeys/