aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-SAP/Makefile26
-rw-r--r--net/p5-Net-SAP/distinfo2
-rw-r--r--net/p5-Net-SAP/pkg-descr7
-rw-r--r--net/p5-Net-SAP/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bb3f6693da7..eedf8dc1650 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -450,6 +450,7 @@
SUBDIR += p5-Net-RawIP
SUBDIR += p5-Net-RawSock
SUBDIR += p5-Net-Rendezvous
+ SUBDIR += p5-Net-SAP
SUBDIR += p5-Net-SCP
SUBDIR += p5-Net-SFTP
SUBDIR += p5-Net-SMPP
diff --git a/net/p5-Net-SAP/Makefile b/net/p5-Net-SAP/Makefile
new file mode 100644
index 00000000000..98b6c50b7b0
--- /dev/null
+++ b/net/p5-Net-SAP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-SAP
+# Date created: Jul 25 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SAP
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.ORG
+COMMENT= Session Announcement Protocol (rfc2974) packet parser
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IO/Socket/Multicast.pm:${PORTSDIR}/net/p5-IO-Socket-Multicast \
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SAP.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SAP/distinfo b/net/p5-Net-SAP/distinfo
new file mode 100644
index 00000000000..db4d9ed057d
--- /dev/null
+++ b/net/p5-Net-SAP/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-SAP-0.01.tar.gz) = 89c7b173f1ca86f7e082a192d822f4d3
+SIZE (Net-SAP-0.01.tar.gz) = 3715
diff --git a/net/p5-Net-SAP/pkg-descr b/net/p5-Net-SAP/pkg-descr
new file mode 100644
index 00000000000..3eae20eb190
--- /dev/null
+++ b/net/p5-Net-SAP/pkg-descr
@@ -0,0 +1,7 @@
+Net::SAP currently provides basic functionality for receiving and parsing
+SAP (RFC2974) multicast packets.
+
+WWW: http://search.cpan.org/dist/Net-SAP/
+
+- Cheng-Lung Sung
+clsung at dragon2.net
diff --git a/net/p5-Net-SAP/pkg-plist b/net/p5-Net-SAP/pkg-plist
new file mode 100644
index 00000000000..eb36bd969b6
--- /dev/null
+++ b/net/p5-Net-SAP/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Net/SAP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SAP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SAP
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true