aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/ruby-gtktrayicon/Makefile29
-rw-r--r--x11/ruby-gtktrayicon/distinfo2
-rw-r--r--x11/ruby-gtktrayicon/pkg-descr4
-rw-r--r--x11/ruby-gtktrayicon/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 37610a0fa5a..b8d0ba83dce 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -147,6 +147,7 @@
SUBDIR += ruby-gnome-all
SUBDIR += ruby-gnome2
SUBDIR += ruby-gnome2-all
+ SUBDIR += ruby-gtktrayicon
SUBDIR += rxvt
SUBDIR += rxvt-devel
SUBDIR += settitle
diff --git a/x11/ruby-gtktrayicon/Makefile b/x11/ruby-gtktrayicon/Makefile
new file mode 100644
index 00000000000..ce4843ad123
--- /dev/null
+++ b/x11/ruby-gtktrayicon/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ruby-gtktrayicon
+# Date created: 29 June 2004
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtktrayicon
+PORTVERSION= 0.1.0
+CATEGORIES= x11 gnome ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ruby-gnome2
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-gtktrayicon-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Ruby binding for GtkTrayIcon
+
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2
+
+USE_RUBY= yes
+USE_GNOME= gtk20
+USE_RUBY_EXTCONF= yes
+USE_XLIB= yes
+
+INSTALL_TARGET= site-install
+
+.include <bsd.port.mk>
diff --git a/x11/ruby-gtktrayicon/distinfo b/x11/ruby-gtktrayicon/distinfo
new file mode 100644
index 00000000000..32498ee171b
--- /dev/null
+++ b/x11/ruby-gtktrayicon/distinfo
@@ -0,0 +1,2 @@
+MD5 (ruby/ruby-gtktrayicon-0.1.0.tar.gz) = 77a47e80a49e5a944da6aaf2768527c8
+SIZE (ruby/ruby-gtktrayicon-0.1.0.tar.gz) = 15174
diff --git a/x11/ruby-gtktrayicon/pkg-descr b/x11/ruby-gtktrayicon/pkg-descr
new file mode 100644
index 00000000000..6cd8203ca9d
--- /dev/null
+++ b/x11/ruby-gtktrayicon/pkg-descr
@@ -0,0 +1,4 @@
+Ruby/GtkTrayIcon is a Ruby binding for the System Tray Protocol
+Specification based on code from the EGG library.
+
+WWW: http://ruby-gnome2.sourceforge.jp/
diff --git a/x11/ruby-gtktrayicon/pkg-plist b/x11/ruby-gtktrayicon/pkg-plist
new file mode 100644
index 00000000000..779bdc7ac8d
--- /dev/null
+++ b/x11/ruby-gtktrayicon/pkg-plist
@@ -0,0 +1,2 @@
+%%RUBY_SITEARCHLIBDIR%%/gtktrayicon.so
+%%RUBY_SITELIBDIR%%/gtktrayicon.rb