aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/ocaml-zip/Makefile54
-rw-r--r--archivers/ocaml-zip/distinfo3
-rw-r--r--archivers/ocaml-zip/pkg-descr6
4 files changed, 64 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 8b245447df7..8b98f99440b 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -58,6 +58,7 @@
SUBDIR += nomarch
SUBDIR += nulib
SUBDIR += nwreckdum
+ SUBDIR += ocaml-zip
SUBDIR += orange
SUBDIR += p5-Archive-Extract
SUBDIR += p5-Archive-Tar
diff --git a/archivers/ocaml-zip/Makefile b/archivers/ocaml-zip/Makefile
new file mode 100644
index 00000000000..5fdd78b1b7f
--- /dev/null
+++ b/archivers/ocaml-zip/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: ocaml-zip
+# Date created: 2006-08-01
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= zip
+PORTVERSION= 1.02
+CATEGORIES= archivers
+MASTER_SITES= http://caml.inria.fr/distrib/bazar-ocaml/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= caml${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= OCaml library to manipulate ZIP/GZIP/JAR archives
+
+#USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_LDCONFIG=yes
+USE_OCAML_WASH= yes
+
+ALL_TARGET= all allopt
+INSTALL_TARGET= install installopt
+MASTERPORT= ${PORTSDIR}/devel/ocaml-camlidl
+PATTERN= ([[:space:]]*)cp([[:space:]]+.*)
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# PREFIX, CFLAGS and permissions safeness
+ @${REINPLACE_CMD} -E \
+ -e "s,${PATTERN},\1\$${BSD_INSTALL_DATA}\2," \
+ -e "s,(-ccopt[[:space:]])-g,\1\"${CFLAGS}\"," \
+ -e "s,^(INSTALLDIR=).*,\1${OCAMLFIND_DESTDIR}/zip," \
+ -e "/ldconf/d" ${WRKSRC}/Makefile
+
+pre-install:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+.if !exists(${OCAMLFIND_LDCONF})
+ ${TOUCH} ${OCAMLFIND_LDCONF}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm ${OCAML_SITELIBDIR}/${PORTNAME}" >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/archivers/ocaml-zip/distinfo b/archivers/ocaml-zip/distinfo
new file mode 100644
index 00000000000..01a73d20199
--- /dev/null
+++ b/archivers/ocaml-zip/distinfo
@@ -0,0 +1,3 @@
+MD5 (camlzip-1.02.tar.gz) = f043818c5525875139debee33427ec1e
+SHA256 (camlzip-1.02.tar.gz) = 0de00d5521d3e49c8c2b1b9bdde362d879b36417360048914ecb1031086299ef
+SIZE (camlzip-1.02.tar.gz) = 24574
diff --git a/archivers/ocaml-zip/pkg-descr b/archivers/ocaml-zip/pkg-descr
new file mode 100644
index 00000000000..d4cb65a190e
--- /dev/null
+++ b/archivers/ocaml-zip/pkg-descr
@@ -0,0 +1,6 @@
+This Objective Caml library provides easy access to compressed files in ZIP
+and GZIP format, as well as to Java JAR files. It provides functions
+for reading from and writing to compressed files in these formats.
+
+Author: Xavier Leroy <Xavier.Leroy@inria.fr>
+WWW: http://pauillac.inria.fr/~xleroy/software.html