aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/fbpanel/Makefile2
-rw-r--r--x11/fbpanel/files/patch-plugins__cpu__cpu.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/x11/fbpanel/Makefile b/x11/fbpanel/Makefile
index 70f31822691..d7422da1e6a 100644
--- a/x11/fbpanel/Makefile
+++ b/x11/fbpanel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fbpanel
PORTVERSION= 6.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11
MASTER_SITES= SF
EXTRACT_SUFX= .tbz2
diff --git a/x11/fbpanel/files/patch-plugins__cpu__cpu.c b/x11/fbpanel/files/patch-plugins__cpu__cpu.c
index 8c50bd994d1..6d78053ace2 100644
--- a/x11/fbpanel/files/patch-plugins__cpu__cpu.c
+++ b/x11/fbpanel/files/patch-plugins__cpu__cpu.c
@@ -82,3 +82,12 @@
#else
static int
cpu_get_load(cpu_priv *c)
+@@ -109,7 +173,7 @@
+ k->set_rows(&c->chart, 1, c->colors);
+ gtk_widget_set_tooltip_markup(((plugin_instance *)c)->pwid, "<b>Cpu</b>");
+ cpu_get_load(c);
+- c->timer = g_timeout_add(1000, (GSourceFunc) cpu_get_load, (gpointer) c);
++ c->timer = g_timeout_add(2000, (GSourceFunc) cpu_get_load, (gpointer) c);
+ RET(1);
+ }
+