aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/atlas-devel/Makefile5
-rw-r--r--math/atlas/Makefile5
-rw-r--r--math/gotoblas/Makefile5
3 files changed, 3 insertions, 12 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index 37a72e6c251..148e54a8dee 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -31,10 +31,7 @@ USE_LDCONFIG= yes
NOT_FOR_ARCHS= alpha
#to compile the ATLAS kernel we use gcc3. See ATLAS/INSTALL.txt for details.
-WANT_FORTRAN= yes
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.if ${OSVERSION} > 700000
BUILD_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
CCOMPILER= gcc34
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index d5cd6969aca..7fece6e77f0 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -30,10 +30,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
#to compile the ATLAS kernel we use gcc3. See ATLAS/INSTALL.txt for details.
-WANT_FORTRAN= yes
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.if ${OSVERSION} > 700000
BUILD_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
CCOMPILER= gcc34
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index ecbf90a4e7b..350328a5c74 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -29,10 +29,7 @@ USE_PERL5= yes
.include <bsd.port.pre.mk>
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.if ${ARCH} == "amd64" || ${ARCH} == "alpha" || ${ARCH} == "sparc64" || ${ARCH} == "ia64"
MAKE_FLAGS+= BINARY64=1