aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Coder-Ovi/Makefile36
-rw-r--r--misc/p5-Geo-Coder-Ovi/distinfo2
-rw-r--r--misc/p5-Geo-Coder-Ovi/pkg-descr4
-rw-r--r--misc/p5-Geo-Coder-Ovi/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 29b891afaa2..ead30f8a23d 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -409,6 +409,7 @@
SUBDIR += p5-Geo-Coder-Multiple
SUBDIR += p5-Geo-Coder-Navteq
SUBDIR += p5-Geo-Coder-OSM
+ SUBDIR += p5-Geo-Coder-Ovi
SUBDIR += p5-Geo-Postcodes
SUBDIR += p5-Geo-Postcodes-DK
SUBDIR += p5-Geo-Postcodes-NO
diff --git a/misc/p5-Geo-Coder-Ovi/Makefile b/misc/p5-Geo-Coder-Ovi/Makefile
new file mode 100644
index 00000000000..82897915dd2
--- /dev/null
+++ b/misc/p5-Geo-Coder-Ovi/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Geo-Coder-Ovi
+# Date created: 2011-10-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-Ovi
+PORTVERSION= 0.02
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geocode addresses with the Ovi Maps API
+
+BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::Ovi.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-Ovi/distinfo b/misc/p5-Geo-Coder-Ovi/distinfo
new file mode 100644
index 00000000000..96231c7bafa
--- /dev/null
+++ b/misc/p5-Geo-Coder-Ovi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coder-Ovi-0.02.tar.gz) = 3592a4e5062fbbe1ed5311a05c2e7d4182aac96249b0963380c310a148c7fa6a
+SIZE (Geo-Coder-Ovi-0.02.tar.gz) = 5440
diff --git a/misc/p5-Geo-Coder-Ovi/pkg-descr b/misc/p5-Geo-Coder-Ovi/pkg-descr
new file mode 100644
index 00000000000..51932c58f1d
--- /dev/null
+++ b/misc/p5-Geo-Coder-Ovi/pkg-descr
@@ -0,0 +1,4 @@
+Geo::Coder::Ovi provides an interface to the geocoding service of the Ovi Maps
+API.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-Ovi/
diff --git a/misc/p5-Geo-Coder-Ovi/pkg-plist b/misc/p5-Geo-Coder-Ovi/pkg-plist
new file mode 100644
index 00000000000..ecb17272e34
--- /dev/null
+++ b/misc/p5-Geo-Coder-Ovi/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Geo/Coder/Ovi.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Ovi/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Ovi
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo