aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Debug-Client/Makefile9
-rw-r--r--devel/p5-List-AllUtils/Makefile9
-rw-r--r--devel/p5-List-Objects-WithUtils/Makefile9
-rw-r--r--devel/p5-Specio/Makefile9
-rw-r--r--devel/p5-Test-DependentModules/Makefile8
-rw-r--r--devel/p5-Text-Levenshtein/Makefile9
-rw-r--r--devel/p5-Types-Core/Makefile8
-rw-r--r--devel/p5-Xporter/Makefile8
-rw-r--r--devel/p5-match-simple/Makefile9
-rw-r--r--devel/p5-mem/Makefile8
-rw-r--r--misc/p5-Geo-Coder-OpenCage/Makefile11
-rw-r--r--www/p5-Net-Async-HTTP/Makefile9
12 files changed, 94 insertions, 12 deletions
diff --git a/devel/p5-Debug-Client/Makefile b/devel/p5-Debug-Client/Makefile
index 7ed36ee419d..5112e56c10d 100644
--- a/devel/p5-Debug-Client/Makefile
+++ b/devel/p5-Debug-Client/Makefile
@@ -27,4 +27,11 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-IO-Socket-IP>=0.21:net/p5-IO-Socket-IP
+RUN_DEPENDS+= p5-IO-Socket-IP>=0.21:net/p5-IO-Socket-IP
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-List-AllUtils/Makefile b/devel/p5-List-AllUtils/Makefile
index cb1ecbe3831..c694c5dd74d 100644
--- a/devel/p5-List-AllUtils/Makefile
+++ b/devel/p5-List-AllUtils/Makefile
@@ -21,4 +21,11 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.31:lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.31:lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-List-Objects-WithUtils/Makefile b/devel/p5-List-Objects-WithUtils/Makefile
index 5b91ab8406e..eec921fa7a4 100644
--- a/devel/p5-List-Objects-WithUtils/Makefile
+++ b/devel/p5-List-Objects-WithUtils/Makefile
@@ -27,4 +27,11 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Specio/Makefile b/devel/p5-Specio/Makefile
index aeea0cb6c83..b7a3cbe34e3 100644
--- a/devel/p5-Specio/Makefile
+++ b/devel/p5-Specio/Makefile
@@ -28,4 +28,11 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-DependentModules/Makefile b/devel/p5-Test-DependentModules/Makefile
index 46f3af39525..2688de85890 100644
--- a/devel/p5-Test-DependentModules/Makefile
+++ b/devel/p5-Test-DependentModules/Makefile
@@ -30,4 +30,10 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502200
+TEST_DEPENDS+= p5-Module-Build>=0:${PORTSDIR}/devel/p5-Module-Build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Text-Levenshtein/Makefile b/devel/p5-Text-Levenshtein/Makefile
index f8f52ce0011..cc8254dea65 100644
--- a/devel/p5-Text-Levenshtein/Makefile
+++ b/devel/p5-Text-Levenshtein/Makefile
@@ -17,4 +17,11 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-Unicode-Collate>=1.04:textproc/p5-Unicode-Collate
+RUN_DEPENDS+= p5-Unicode-Collate>=1.04:textproc/p5-Unicode-Collate
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Types-Core/Makefile b/devel/p5-Types-Core/Makefile
index c9e510a0fac..14058cca2dc 100644
--- a/devel/p5-Types-Core/Makefile
+++ b/devel/p5-Types-Core/Makefile
@@ -22,4 +22,10 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.86:devel/p5-ExtUtils-MakeMaker
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Xporter/Makefile b/devel/p5-Xporter/Makefile
index 188df902cd5..657e98701a9 100644
--- a/devel/p5-Xporter/Makefile
+++ b/devel/p5-Xporter/Makefile
@@ -22,4 +22,10 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.86:devel/p5-ExtUtils-MakeMaker
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-match-simple/Makefile b/devel/p5-match-simple/Makefile
index 7e28918594e..61cfb099fed 100644
--- a/devel/p5-match-simple/Makefile
+++ b/devel/p5-match-simple/Makefile
@@ -24,4 +24,11 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.33:lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-mem/Makefile b/devel/p5-mem/Makefile
index 280f104364d..6efd1fa7a1b 100644
--- a/devel/p5-mem/Makefile
+++ b/devel/p5-mem/Makefile
@@ -18,4 +18,10 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.82:devel/p5-ExtUtils-MakeMaker
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-OpenCage/Makefile b/misc/p5-Geo-Coder-OpenCage/Makefile
index f3ced45ef4b..d9814510fbd 100644
--- a/misc/p5-Geo-Coder-OpenCage/Makefile
+++ b/misc/p5-Geo-Coder-OpenCage/Makefile
@@ -25,4 +25,13 @@ NO_ARCH= yes
USE_PERL5= configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-HTTP-Tiny>=0.028:www/p5-HTTP-Tiny \
+ p5-Pod-Perldoc>=3.21:textproc/p5-Pod-Perldoc
+RUN_DEPENDS+= p5-HTTP-Tiny>=0.028:www/p5-HTTP-Tiny \
+ p5-Pod-Perldoc>=3.21:textproc/p5-Pod-Perldoc
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Net-Async-HTTP/Makefile b/www/p5-Net-Async-HTTP/Makefile
index 9f095df0250..b639d538188 100644
--- a/www/p5-Net-Async-HTTP/Makefile
+++ b/www/p5-Net-Async-HTTP/Makefile
@@ -34,4 +34,11 @@ USES= perl5
SSL_BUILD_DEPENDS= p5-IO-Async-SSL>=0.12:security/p5-IO-Async-SSL
SSL_RUN_DEPENDS= p5-IO-Async-SSL>=0.12:security/p5-IO-Async-SSL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 502000
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.29:lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.29:lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>