aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/gnomermind/Makefile6
-rw-r--r--net/xtraceroute/Makefile7
-rw-r--r--www/encompass/Makefile5
3 files changed, 14 insertions, 4 deletions
diff --git a/games/gnomermind/Makefile b/games/gnomermind/Makefile
index 3ac61356fa3..519581ca709 100644
--- a/games/gnomermind/Makefile
+++ b/games/gnomermind/Makefile
@@ -13,12 +13,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sobomax@FreeBSD.org
+BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
+
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib" \
+ MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
+ XGETTEXT="${LOCALBASE}/bin/xgettext-old"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/net/xtraceroute/Makefile b/net/xtraceroute/Makefile
index 9cf7ea8e50b..8a97add6995 100644
--- a/net/xtraceroute/Makefile
+++ b/net/xtraceroute/Makefile
@@ -13,7 +13,8 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DATAFILES}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/bin/host:${PORTSDIR}/net/host
+BUILD_DEPENDS= ${LOCALBASE}/bin/host:${PORTSDIR}/net/host \
+ msgfmt-old:${PORTSDIR}/devel/gettext-old
LIB_DEPENDS= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
RUN_DEPENDS= ${LOCALBASE}/bin/host:${PORTSDIR}/net/host
@@ -26,7 +27,9 @@ CONFIGURE_ARGS= --with-GL-prefix=${X11BASE}/lib \
--with-lib-GL \
--with-host=${LOCALBASE}/bin/host
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
+ XGETTEXT="${LOCALBASE}/bin/xgettext-old"
DATAFILES= ndg_files.tar.gz
diff --git a/www/encompass/Makefile b/www/encompass/Makefile
index f0ad7f2be23..a3aa69666bb 100644
--- a/www/encompass/Makefile
+++ b/www/encompass/Makefile
@@ -16,6 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sobomax@FreeBSD.org
+BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
LIB_DEPENDS= neon.19:${PORTSDIR}/www/neon \
elysium.0:${PORTSDIR}/misc/libelysium
@@ -23,7 +24,9 @@ USE_GNOME= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
+ XGETTEXT="${LOCALBASE}/bin/xgettext-old"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \