aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--converters/aish/Makefile10
-rw-r--r--converters/ascii2binary/Makefile7
2 files changed, 6 insertions, 11 deletions
diff --git a/converters/aish/Makefile b/converters/aish/Makefile
index c4d361818a1..7086ebe07e2 100644
--- a/converters/aish/Makefile
+++ b/converters/aish/Makefile
@@ -10,14 +10,10 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}u
MAINTAINER= ports@FreeBSD.org
COMMENT= Ish/uuencode/Base64 converter
-NO_STAGE= yes
-
-.include <bsd.port.options.mk>
+MAKE_ARGS= DSTDIR=${STAGEDIR}${PREFIX}/bin
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${PREFIX}/share/doc/ja/aish
- ${INSTALL_DATA} ${WRKSRC}/aish.txt ${PREFIX}/share/doc/ja/aish
-.endif
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/ja/aish
+ ${INSTALL_DATA} ${WRKSRC}/aish.txt ${STAGEDIR}${PREFIX}/share/doc/ja/aish
.include <bsd.port.mk>
diff --git a/converters/ascii2binary/Makefile b/converters/ascii2binary/Makefile
index af6ba173002..a3731c01f42 100644
--- a/converters/ascii2binary/Makefile
+++ b/converters/ascii2binary/Makefile
@@ -19,11 +19,10 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PLIST_FILES= bin/ascii2binary bin/binary2ascii
+PLIST_FILES= bin/ascii2binary bin/binary2ascii \
+ man/man1/ascii2binary.1.gz \
+ man/man1/binary2ascii.1.gz
-MAN1= ascii2binary.1 binary2ascii.1
-
-NO_STAGE= yes
pre-configure:
${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|" ${WRKSRC}/Makefile.in