aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Image-Math-Constrain/Makefile25
-rw-r--r--graphics/p5-Image-Math-Constrain/distinfo3
-rw-r--r--graphics/p5-Image-Math-Constrain/pkg-descr3
-rw-r--r--graphics/p5-Image-Math-Constrain/pkg-plist9
5 files changed, 41 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4db06192309..a0df32de153 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -483,6 +483,7 @@
SUBDIR += p5-Image-Imlib2
SUBDIR += p5-Image-Info
SUBDIR += p5-Image-Magick-Iterator
+ SUBDIR += p5-Image-Math-Constrain
SUBDIR += p5-Image-MetaData-GQview
SUBDIR += p5-Image-MetaData-JPEG
SUBDIR += p5-Image-PBMlib
diff --git a/graphics/p5-Image-Math-Constrain/Makefile b/graphics/p5-Image-Math-Constrain/Makefile
new file mode 100644
index 00000000000..4ada1f52a30
--- /dev/null
+++ b/graphics/p5-Image-Math-Constrain/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Image-Math-Constrain
+# Date created: 8 September 2007
+# Whom: coryking
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image-Math-Constrain
+PORTVERSION= 1.01
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Image
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= coryking@mozimedia.com
+COMMENT= Scaling math used in image size constraining (such as thumbnails)
+
+BUILD_DEPENDS= p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS= p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools
+
+PERL_CONFIGURE= yes
+
+MAN3= Image::Math::Constrain.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Math-Constrain/distinfo b/graphics/p5-Image-Math-Constrain/distinfo
new file mode 100644
index 00000000000..71657afeb9f
--- /dev/null
+++ b/graphics/p5-Image-Math-Constrain/distinfo
@@ -0,0 +1,3 @@
+MD5 (Image-Math-Constrain-1.01.tar.gz) = 92980c42977b0dfe9dba715d405313b0
+SHA256 (Image-Math-Constrain-1.01.tar.gz) = 7ff525a748d9cd445f48791afde41f48f65a78da4aff94bfb2c962167642e6df
+SIZE (Image-Math-Constrain-1.01.tar.gz) = 26920
diff --git a/graphics/p5-Image-Math-Constrain/pkg-descr b/graphics/p5-Image-Math-Constrain/pkg-descr
new file mode 100644
index 00000000000..a78b1980401
--- /dev/null
+++ b/graphics/p5-Image-Math-Constrain/pkg-descr
@@ -0,0 +1,3 @@
+Scaling math used in image size constraining (such as thumbnails)
+
+WWW: http://search.cpan.org/dist/Image-Math-Constrain/
diff --git a/graphics/p5-Image-Math-Constrain/pkg-plist b/graphics/p5-Image-Math-Constrain/pkg-plist
new file mode 100644
index 00000000000..d6b7e5eef6e
--- /dev/null
+++ b/graphics/p5-Image-Math-Constrain/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Image/Math/Constrain.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Math/Constrain/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Image/Math
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Image
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Math/Constrain
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image/Math
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Image
+@dirrmtry %%SITE_PERL%%/Image/Math
+@dirrmtry %%SITE_PERL%%/Image