aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/fpc-ldap/Makefile23
-rw-r--r--net/fpc-ldap/pkg-plist12
3 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 98cf3c4e21a..d9c17e7eabe 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -147,6 +147,7 @@
SUBDIR += flowgrep
SUBDIR += fonulator
SUBDIR += forg
+ SUBDIR += fpc-ldap
SUBDIR += fpc-pcap
SUBDIR += fping
SUBDIR += fping+ipv6
diff --git a/net/fpc-ldap/Makefile b/net/fpc-ldap/Makefile
new file mode 100644
index 00000000000..7133eb01abe
--- /dev/null
+++ b/net/fpc-ldap/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-ldap
+# Date created: 2010-04-22
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= net lang
+PKGNAMESUFFIX= -ldap
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to OpenLDAP
+
+USE_FPC= hash
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= OPENLDAP "Install OpenLDAP libraries" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/fpc-ldap/pkg-plist b/net/fpc-ldap/pkg-plist
new file mode 100644
index 00000000000..72c385803f4
--- /dev/null
+++ b/net/fpc-ldap/pkg-plist
@@ -0,0 +1,12 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ldap/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ldap/lber.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ldap/ldap.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ldap/lber.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ldap/ldap.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ldap/libplber.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ldap/libpldap.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/ldap
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc