aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/nss/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index d5914143e27..bcc9383f39e 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -23,6 +23,7 @@ USE_PERL5_BUILD= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
+USE_REINPLACE= yes
MAKE_ENV= BSD_LDOPTS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
BUILD_OPT=1
ALL_TARGET= nss_build_all
@@ -32,6 +33,10 @@ DIST= ${WRKSRC}/../../dist
CONFLICTS= btoa-5.* digest-* emboss-2.4.* oases-2.* p5-PAR-0.*
+post-patch:
+ @${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" \
+ ${WRKSRC}/../../security/coreconf/FreeBSD.mk
+
do-install:
${MKDIR} ${PREFIX}/include/nss
${TAR} -C ${DIST}/public --dereference -cf - . | \