aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/dirvish/Makefile7
-rw-r--r--sysutils/dirvish/distinfo4
-rw-r--r--sysutils/dirvish/files/patch-install.sh68
3 files changed, 72 insertions, 7 deletions
diff --git a/sysutils/dirvish/Makefile b/sysutils/dirvish/Makefile
index 849c6f7563e..225b661b836 100644
--- a/sysutils/dirvish/Makefile
+++ b/sysutils/dirvish/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= dirvish
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.2.1
CATEGORIES= sysutils archivers
MASTER_SITES= http://www.dirvish.org/
-DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+EXTRACT_SUFX= .tgz
MAINTAINER= lorenl@alzatex.com
COMMENT= Network backup system based off of rsync
@@ -22,8 +21,6 @@ RUN_DEPENDS= ${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
MAN5= dirvish.conf.5
MAN8= dirvish.8 dirvish-expire.8 dirvish-locate.8 dirvish-runall.8
-WRKSRC= ${WRKDIR}/Dirvish-${PORTVERSION}
-
NO_BUILD= yes
USE_PERL5_RUN= yes
diff --git a/sysutils/dirvish/distinfo b/sysutils/dirvish/distinfo
index dc8d72105a4..cb2274b909c 100644
--- a/sysutils/dirvish/distinfo
+++ b/sysutils/dirvish/distinfo
@@ -1,2 +1,2 @@
-MD5 (dirvish_1.2.orig.tar.gz) = 0b972fecae018a4fc96960ff0459b8c3
-SIZE (dirvish_1.2.orig.tar.gz) = 46131
+MD5 (dirvish-1.2.1.tgz) = 51dd3f38f0bddb45b67d69b29af333c0
+SIZE (dirvish-1.2.1.tgz) = 49132
diff --git a/sysutils/dirvish/files/patch-install.sh b/sysutils/dirvish/files/patch-install.sh
new file mode 100644
index 00000000000..d96c1f2516f
--- /dev/null
+++ b/sysutils/dirvish/files/patch-install.sh
@@ -0,0 +1,68 @@
+--- install.sh.orig Fri Feb 18 16:56:13 2005
++++ install.sh Thu Jun 16 14:17:32 2005
+@@ -9,6 +9,8 @@ case `echo "testing\c"; echo 1,2,3`,`ech
+ *) ECHO_N= ECHO_C='\c' ECHO_T= ;;
+ esac
+
++ECHO_N=
++
+ EXECUTABLES="dirvish dirvish-runall dirvish-expire dirvish-locate"
+ MANPAGES="dirvish.8 dirvish-runall.8 dirvish-expire.8 dirvish-locate.8"
+ MANPAGES="$MANPAGES dirvish.conf.5"
+@@ -29,6 +31,7 @@ do
+
+ until [ -n "$PREFIX_OK" ]
+ do
++ PREFIX="/usr/local"
+ EXECDIR="/usr/sbin"
+ CONFDIR="/etc/dirvish"
+ MANDIR="/usr/share/man"
+@@ -61,9 +64,9 @@ do
+
+ if [ -d "$PREFIX/sbin" ]
+ then
+- BINDIR=$PREFIX/sbin
++ BINDIR="$PREFIX/sbin"
+ else
+- BINDIR=$PREFIX/bin
++ BINDIR="$PREFIX/bin"
+ fi
+
+ if [ -d "$PREFIX/share/man" ]
+@@ -74,13 +77,16 @@ do
+ MANDIR=$PREFIX/usr/share/man
+ eli [ -d "$PREFIX/usr/man" ]
+ then
+- MANDIR="$PREFIX/usr/man" ]
++ MANDIR="$PREFIX/usr/man"
+ else
+- MANDIR=$PREFIX/man
++ MANDIR="$PREFIX/man"
+ fi
+ if [ `expr "$PREFIX" : '.*dirvish.*'` -gt 0 ]
+ then
+ CONFDIR="$PREFIX/etc"
++ elif [ -d "$PREFIX/etc" ]
++ then
++ CONFDIR="$PREFIX/etc/dirvish"
+ else
+ CONFDIR="/etc/dirvish"
+ fi
+@@ -124,7 +130,7 @@ EOSTAT
+ if [ `expr "$ans" : '[qQ]'` -ne 0 ]
+ then
+ exit
+- elif [ `expr "$ans" : '[yY]'` -ne 0 ]
++ elif [ `expr "$ans" : '[nN]'` -eq 0 ]
+ then
+ break
+ fi
+@@ -150,7 +156,7 @@ echo
+
+ echo $ECHO_N "Install executables and manpages? (no/yes) $ECHO_C"
+ read ans
+-if [ `expr "$ans" : '[yY]'` -ne 0 ]
++if [ `expr "$ans" : '[nN]'` -eq 0 ]
+ then
+ echo
+ if [ -n "$CREATE_PREFIX" ]