aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/p5-Kwiki-ModPerl/Makefile14
-rw-r--r--www/p5-Kwiki-ModPerl/distinfo4
-rw-r--r--www/p5-Kwiki-ModPerl/pkg-message40
3 files changed, 38 insertions, 20 deletions
diff --git a/www/p5-Kwiki-ModPerl/Makefile b/www/p5-Kwiki-ModPerl/Makefile
index e51108d8b40..1ac9f73ee0c 100644
--- a/www/p5-Kwiki-ModPerl/Makefile
+++ b/www/p5-Kwiki-ModPerl/Makefile
@@ -6,25 +6,25 @@
#
PORTNAME= Kwiki-ModPerl
-PORTVERSION= 0.06
+PORTVERSION= 0.08
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Kwiki
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= apeiron+ports@coitusmentis.info
COMMENT= Enable Kwiki to work under mod_perl
BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_REINPLACE= yes
PERL_CONFIGURE= yes
.if defined(WITH_APACHE2)
-BROKEN= Broken due the new mod_perl2 API
BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
pre-patch:
- @${REINPLACE_CMD} -e 's|mod_perl|Apache2::mod_perl|g' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -e 's|mod_perl|mod_perl2|g' ${WRKSRC}/Makefile.PL
.else
BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
.endif
@@ -34,7 +34,11 @@ MAN3= Kwiki::ModPerl.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
-IGNORE= This port requires perl 5.8.x or later. Install lang/perl5.8 then try again
+IGNORE= requires Perl 5.8.0 or later. Install lang/perl5.8 then try again
+.elif defined(WITH_APACHE2) && ${PERL_LEVEL} < 500807
+# Recent versions of mod_perl2 require a newer version of CGI.pm than is
+# shipped with Perl < 5.8.7.
+BUILD_DEPENDS+= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
.endif
post-install:
diff --git a/www/p5-Kwiki-ModPerl/distinfo b/www/p5-Kwiki-ModPerl/distinfo
index dc07e794947..b6a156226a5 100644
--- a/www/p5-Kwiki-ModPerl/distinfo
+++ b/www/p5-Kwiki-ModPerl/distinfo
@@ -1,2 +1,2 @@
-MD5 (Kwiki-ModPerl-0.06.tar.gz) = b27b50056ba8b2557ce808ec84ebe222
-SIZE (Kwiki-ModPerl-0.06.tar.gz) = 9726
+MD5 (Kwiki-ModPerl-0.08.tar.gz) = 370edecf467f239c030dd6a3860eb6f7
+SIZE (Kwiki-ModPerl-0.08.tar.gz) = 9927
diff --git a/www/p5-Kwiki-ModPerl/pkg-message b/www/p5-Kwiki-ModPerl/pkg-message
index 24679822ada..9ff5c9c5916 100644
--- a/www/p5-Kwiki-ModPerl/pkg-message
+++ b/www/p5-Kwiki-ModPerl/pkg-message
@@ -1,23 +1,37 @@
/* ================================================================= */
Note:
Kwiki-ModPerl plugin installed! Now you should modify
- your Apache configuration:
+ your Apache configuration:
- <Location /kwiki>
- SetHandler perl-script
- PerlSetVar KwikiBaseDir /path/to/webroot/kwiki
- PerlHandler +Kwiki::ModPerl
- </Location>
+ <Location /kwiki>
+ SetHandler perl-script
+ PerlSetVar KwikiBaseDir /path/to/webroot/kwiki
+ PerlHandler +Kwiki::ModPerl
+ </Location>
- If you have a custom lib directory for your Kwiki:
+ If you have a custom lib directory for your Kwiki:
- <Perl>
- use lib '/path/to/webroot/kwiki/lib';
- </Perl>
+ <Perl>
+ use lib '/path/to/webroot/kwiki/lib';
+ </Perl>
- If you're using mod_perl2, please add the following line
- into your httpd.conf:
+ If you're using mod_perl2, please ensure that the following
+ modules are referenced by either your httpd.conf or a file
+ referenced by a PerlRequire directive:
- PerlModule Apache2
+ Apache2::URI
+ Apache2::SubRequest
+ Apache2::ServerUtil
+ Apache2::Response
+ Apache2::RequestUtil
+ Apache2::RequestIO
+ Apache2::Request
+ Apache2::Log
+ Apache2::Access
+ Apache2::Const
+ APR::Table
+
+ Most mod_perl 2 applications require these modules at a minimum, so you
+ may have them listed already.
/* ================================================================= */