aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/linux_base/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/emulators/linux_base/Makefile b/emulators/linux_base/Makefile
index ff6484ab155..b8d6f9267c7 100644
--- a/emulators/linux_base/Makefile
+++ b/emulators/linux_base/Makefile
@@ -137,6 +137,12 @@ pre-install:
.endif
do-install:
+# Make sure we have a /dev/null in the chrooted environment.
+ @${MKDIR} ${LINUXBASE}/dev
+ @${RM} -f ${LINUXBASE}/dev/null
+ @mknod ${LINUXBASE}/dev/null c 2 2
+ @${CHMOD} 666 ${LINUXBASE}/dev/null
+#
@${MKDIR} ${LINUXBASE}/${DBPATH}
@${MKDIR} ${LINUXBASE}/var/tmp ${LINUXBASE}/lib
@cd ${LINUXBASE}/lib && ${LN} -sf libtermcap.so.2.0.8 libtermcap.so.2