aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/python/Makefile1
-rw-r--r--lang/python/files/patch-configure17
-rw-r--r--lang/python/files/patch-pyconfig.h.in11
-rw-r--r--lang/python23/Makefile1
-rw-r--r--lang/python23/files/patch-configure17
-rw-r--r--lang/python23/files/patch-pyconfig.h.in11
-rw-r--r--lang/python24/Makefile1
-rw-r--r--lang/python24/files/patch-configure17
-rw-r--r--lang/python24/files/patch-pyconfig.h.in11
9 files changed, 75 insertions, 12 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 6abf5a00434..760b589fa0e 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
diff --git a/lang/python/files/patch-configure b/lang/python/files/patch-configure
index c17e753795a..60016879c44 100644
--- a/lang/python/files/patch-configure
+++ b/lang/python/files/patch-configure
@@ -1,7 +1,7 @@
---- configure.orig Sun Jul 13 18:46:13 2003
-+++ configure Sat Jul 19 15:21:09 2003
-@@ -3288,6 +3288,12 @@
- RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
+--- configure.orig Sun Sep 21 00:29:40 2003
++++ configure Fri Sep 26 13:08:51 2003
+@@ -3596,6 +3596,12 @@
+ RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
+ FreeBSD*)
@@ -13,3 +13,12 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
+@@ -13384,7 +13390,7 @@
+ (exit $ac_status); }; }; then
+
+ cat >>confdefs.h <<\_ACEOF
+-#define HAVE_SYNC 1
++#define HAVE_FSYNC 1
+ _ACEOF
+
+ echo "$as_me:$LINENO: result: yes" >&5
diff --git a/lang/python/files/patch-pyconfig.h.in b/lang/python/files/patch-pyconfig.h.in
new file mode 100644
index 00000000000..289f4dcafca
--- /dev/null
+++ b/lang/python/files/patch-pyconfig.h.in
@@ -0,0 +1,11 @@
+--- pyconfig.h.in.orig Fri Sep 26 13:09:17 2003
++++ pyconfig.h.in Fri Sep 26 13:09:25 2003
+@@ -486,7 +486,7 @@
+ #undef HAVE_SYMLINK
+
+ /* Define if you have the 'fsync' function. */
+-#undef HAVE_SYNC
++#undef HAVE_FSYNC
+
+ /* Define to 1 if you have the `sysconf' function. */
+ #undef HAVE_SYSCONF
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 6abf5a00434..760b589fa0e 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
diff --git a/lang/python23/files/patch-configure b/lang/python23/files/patch-configure
index c17e753795a..60016879c44 100644
--- a/lang/python23/files/patch-configure
+++ b/lang/python23/files/patch-configure
@@ -1,7 +1,7 @@
---- configure.orig Sun Jul 13 18:46:13 2003
-+++ configure Sat Jul 19 15:21:09 2003
-@@ -3288,6 +3288,12 @@
- RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
+--- configure.orig Sun Sep 21 00:29:40 2003
++++ configure Fri Sep 26 13:08:51 2003
+@@ -3596,6 +3596,12 @@
+ RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
+ FreeBSD*)
@@ -13,3 +13,12 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
+@@ -13384,7 +13390,7 @@
+ (exit $ac_status); }; }; then
+
+ cat >>confdefs.h <<\_ACEOF
+-#define HAVE_SYNC 1
++#define HAVE_FSYNC 1
+ _ACEOF
+
+ echo "$as_me:$LINENO: result: yes" >&5
diff --git a/lang/python23/files/patch-pyconfig.h.in b/lang/python23/files/patch-pyconfig.h.in
new file mode 100644
index 00000000000..289f4dcafca
--- /dev/null
+++ b/lang/python23/files/patch-pyconfig.h.in
@@ -0,0 +1,11 @@
+--- pyconfig.h.in.orig Fri Sep 26 13:09:17 2003
++++ pyconfig.h.in Fri Sep 26 13:09:25 2003
+@@ -486,7 +486,7 @@
+ #undef HAVE_SYMLINK
+
+ /* Define if you have the 'fsync' function. */
+-#undef HAVE_SYNC
++#undef HAVE_FSYNC
+
+ /* Define to 1 if you have the `sysconf' function. */
+ #undef HAVE_SYSCONF
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 6abf5a00434..760b589fa0e 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
diff --git a/lang/python24/files/patch-configure b/lang/python24/files/patch-configure
index c17e753795a..60016879c44 100644
--- a/lang/python24/files/patch-configure
+++ b/lang/python24/files/patch-configure
@@ -1,7 +1,7 @@
---- configure.orig Sun Jul 13 18:46:13 2003
-+++ configure Sat Jul 19 15:21:09 2003
-@@ -3288,6 +3288,12 @@
- RUNSHARED=LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
+--- configure.orig Sun Sep 21 00:29:40 2003
++++ configure Fri Sep 26 13:08:51 2003
+@@ -3596,6 +3596,12 @@
+ RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
+ FreeBSD*)
@@ -13,3 +13,12 @@
hp*|HP*)
LDLIBRARY='libpython$(VERSION).sl'
BLDLIBRARY='-Wl,+b,$(LIBDIR) -L. -lpython$(VERSION)'
+@@ -13384,7 +13390,7 @@
+ (exit $ac_status); }; }; then
+
+ cat >>confdefs.h <<\_ACEOF
+-#define HAVE_SYNC 1
++#define HAVE_FSYNC 1
+ _ACEOF
+
+ echo "$as_me:$LINENO: result: yes" >&5
diff --git a/lang/python24/files/patch-pyconfig.h.in b/lang/python24/files/patch-pyconfig.h.in
new file mode 100644
index 00000000000..289f4dcafca
--- /dev/null
+++ b/lang/python24/files/patch-pyconfig.h.in
@@ -0,0 +1,11 @@
+--- pyconfig.h.in.orig Fri Sep 26 13:09:17 2003
++++ pyconfig.h.in Fri Sep 26 13:09:25 2003
+@@ -486,7 +486,7 @@
+ #undef HAVE_SYMLINK
+
+ /* Define if you have the 'fsync' function. */
+-#undef HAVE_SYNC
++#undef HAVE_FSYNC
+
+ /* Define to 1 if you have the `sysconf' function. */
+ #undef HAVE_SYSCONF