aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Twitter-Lite/Makefile27
-rw-r--r--net/p5-Net-Twitter-Lite/distinfo3
-rw-r--r--net/p5-Net-Twitter-Lite/pkg-descr11
-rw-r--r--net/p5-Net-Twitter-Lite/pkg-plist9
5 files changed, 51 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a155b5a3c0d..aa841b12d78 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -595,6 +595,7 @@
SUBDIR += p5-Net-Traceroute6
SUBDIR += p5-Net-Trackback
SUBDIR += p5-Net-Twitter
+ SUBDIR += p5-Net-Twitter-Lite
SUBDIR += p5-Net-VNC
SUBDIR += p5-Net-Wake
SUBDIR += p5-Net-Whois
diff --git a/net/p5-Net-Twitter-Lite/Makefile b/net/p5-Net-Twitter-Lite/Makefile
new file mode 100644
index 00000000000..e568d14c8a7
--- /dev/null
+++ b/net/p5-Net-Twitter-Lite/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-Twitter-Lite
+# Date created: Aug 2, 2009
+# Whom: Masafumi NAKANE <max@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Twitter-Lite
+PORTVERSION= 0.06002
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= max@FreeBSD.org
+COMMENT= A perl interface to the Twitter API
+
+BUILD_DEPENDS= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-JSON-Any>=1.21:${PORTSDIR}/converters/p5-JSON-Any \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ p5-Net-OAuth>=0.16:${PORTSDIR}/net/p5-Net-OAuth
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN3= Net::Twitter::Lite.3 Net::Twitter::Lite::Error.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Twitter-Lite/distinfo b/net/p5-Net-Twitter-Lite/distinfo
new file mode 100644
index 00000000000..2baff697a7d
--- /dev/null
+++ b/net/p5-Net-Twitter-Lite/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Twitter-Lite-0.06002.tar.gz) = 041354bb288fb56ddb5e9c6d04a13414
+SHA256 (Net-Twitter-Lite-0.06002.tar.gz) = 1dea726e6501f394aa18fc46748c46793aeee3636bd416594fa0e25d7b7b8d11
+SIZE (Net-Twitter-Lite-0.06002.tar.gz) = 60354
diff --git a/net/p5-Net-Twitter-Lite/pkg-descr b/net/p5-Net-Twitter-Lite/pkg-descr
new file mode 100644
index 00000000000..f2d274cc5c0
--- /dev/null
+++ b/net/p5-Net-Twitter-Lite/pkg-descr
@@ -0,0 +1,11 @@
+This module provides a perl interface to the Twitter APIs. It uses the
+same API definitions as Net::Twitter, but without the extra bells and
+whistles and without the additional dependencies. Same great taste,
+less filling.
+
+This module is related to, but is not part of the "Net::Twitter"
+distribution. It's API methods and API method documentation are
+generated from "Net::Twitter"'s internals. It exists for those who
+cannot, or prefer not to install Moose and its dependencies.
+
+WWW: http://search.cpan.org/dist/Net-Twitter-Lite/
diff --git a/net/p5-Net-Twitter-Lite/pkg-plist b/net/p5-Net-Twitter-Lite/pkg-plist
new file mode 100644
index 00000000000..b779f888a41
--- /dev/null
+++ b/net/p5-Net-Twitter-Lite/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Net/Twitter/Lite.pm
+%%SITE_PERL%%/Net/Twitter/Lite/Error.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Twitter/Lite/.packlist
+@dirrmtry %%SITE_PERL%%/Net/Twitter/Lite
+@dirrmtry %%SITE_PERL%%/Net/Twitter
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Twitter/Lite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Twitter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net