aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/bigloo/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/bigloo/Makefile b/lang/bigloo/Makefile
index 03c856914e7..ddc2d0d7f7e 100644
--- a/lang/bigloo/Makefile
+++ b/lang/bigloo/Makefile
@@ -33,6 +33,12 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
INSTALL_INFO?= install-info
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile due to varargs.h being deprecated"
+.endif
+
post-install: install-info
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/bigloo.sh | ${SED} "s|%%BIGLOO_VERSION%%|${PORTVERSION}|g" > ${PREFIX}/etc/rc.d/000.bigloo.sh
@${CHMOD} 750 ${PREFIX}/etc/rc.d/000.bigloo.sh
@@ -43,4 +49,4 @@ install-info:
test: build
@(cd ${WRKSRC}; ${GMAKE} test)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>