aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/csmash/Makefile8
-rw-r--r--games/csmash/files/patch-loadparts.cpp11
2 files changed, 12 insertions, 7 deletions
diff --git a/games/csmash/Makefile b/games/csmash/Makefile
index f1db947e871..b8cbe342eaf 100644
--- a/games/csmash/Makefile
+++ b/games/csmash/Makefile
@@ -25,14 +25,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|/games/|/|g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/csmash/files/patch-loadparts.cpp b/games/csmash/files/patch-loadparts.cpp
new file mode 100644
index 00000000000..cab4e05cc79
--- /dev/null
+++ b/games/csmash/files/patch-loadparts.cpp
@@ -0,0 +1,11 @@
+--- loadparts.cpp.orig Wed May 4 19:19:33 2005
++++ loadparts.cpp Wed May 4 19:19:48 2005
+@@ -245,7 +245,7 @@
+
+ while ('\\' == line[l-1]) {
+ // concat next line(s)
+- int bufsize = clamp(0U, sizeof(line)-l, sizeof(line)-1);
++ int bufsize = clamp(0UL, sizeof(line)-l, sizeof(line)-1);
+ fgets(&line[l-2], bufsize, fp);
+ if (feof((FILE*)fp)) break;
+ l = strlen(line);