aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--finance/pfpro/Makefile10
-rw-r--r--finance/pfpro/files/patch-pfpro.c12
-rw-r--r--finance/pfpro/files/pkg-message.in7
-rw-r--r--finance/pfpro/pkg-plist5
4 files changed, 27 insertions, 7 deletions
diff --git a/finance/pfpro/Makefile b/finance/pfpro/Makefile
index 56f15e041bc..75e4f10b3b1 100644
--- a/finance/pfpro/Makefile
+++ b/finance/pfpro/Makefile
@@ -7,12 +7,12 @@
PORTNAME= pfpro
PORTVERSION= 3.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance
MASTER_SITES= #https://manager.verisign.com/
DISTNAME= pfpro_freebsd
-MAINTAINER= durian@shadetreesoftware.com
+MAINTAINER= never@nevermind.kiev.ua
COMMENT= SDK for VeriSign's PayFlow Pro
ONLY_FOR_ARCHS= i386
@@ -24,8 +24,9 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
LATEST_LINK= verisign-pfpro
-CERTDIR= ${PREFIX}/certs
+CERTDIR= ${PREFIX}/etc/pfpro/certs
FBSDDIR= ${WRKSRC}/verisign/payflowpro/freebsd
+PATCH_WRKSRC= ${WRKSRC}/verisign/payflowpro/freebsd/bin
PFCFLAGS= -DUSE_SSLEAY -fPIC -DFREEBSD_OS -DGENERIC_SEED -D_REENTRANT -pthread -DPTHREADS -I. -L.
# XXX nees to be the same as DISTFILES
@@ -45,6 +46,9 @@ some terms and conditions. After downing the SDK, place ${PFP_BUNDLE}\n\
in ${DISTDIR}.\n
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${FBSDDIR}/bin/pfpro.c
+
do-build:
(cd ${FBSDDIR}/lib && ${CC} ${PFCFLAGS} ${CFLAGS} -c ../bin/${PORTNAME}.c -o ${PORTNAME}.o && ${CC} ${PFCFLAGS} ${CFLAGS} -lpfpro ${PORTNAME}.o -o ${PORTNAME})
diff --git a/finance/pfpro/files/patch-pfpro.c b/finance/pfpro/files/patch-pfpro.c
new file mode 100644
index 00000000000..3263e86a2d0
--- /dev/null
+++ b/finance/pfpro/files/patch-pfpro.c
@@ -0,0 +1,12 @@
+--- pfpro.c.orig Fri Jun 16 00:37:48 2006
++++ pfpro.c Fri Jun 16 01:01:27 2006
+@@ -65,6 +65,9 @@
+ int parmLen;
+
+
++ /* Set default value of PFPRO_CERT_PATH */
++ setenv("PFPRO_CERT_PATH","%%PREFIX%%/etc/pfpro/certs",0);
++
+ if ((argc == 2) && (!strcmp(argv[1],"-i"))) {
+ /* read input from stdin */
+ if (!fgets(ibuf,sizeof(ibuf),stdin)) {
diff --git a/finance/pfpro/files/pkg-message.in b/finance/pfpro/files/pkg-message.in
index 38b6b1fb18d..0413a655af8 100644
--- a/finance/pfpro/files/pkg-message.in
+++ b/finance/pfpro/files/pkg-message.in
@@ -1,3 +1,6 @@
+======================================================================
You must set the environment variable PFPRO_CERT_PATH to point to
-the directory that contains the file f73e89fd.0. The default location
-is: %%PREFIX%%/certs
+the directory that contains the file f73e89fd.0.
+
+The default location is: %%PREFIX%%/etc/pfpro/certs
+======================================================================
diff --git a/finance/pfpro/pkg-plist b/finance/pfpro/pkg-plist
index 1830f72bee0..b42e24d5a4f 100644
--- a/finance/pfpro/pkg-plist
+++ b/finance/pfpro/pkg-plist
@@ -1,5 +1,6 @@
bin/pfpro
-certs/f73e89fd.0
+etc/pfpro/certs/f73e89fd.0
include/pfpro.h
lib/libpfpro.so
-@dirrmtry certs
+@dirrmtry etc/pfpro/certs
+@dirrmtry etc/pfpro