aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/php5/Makefile.ext9
-rw-r--r--lang/php53/Makefile.ext9
2 files changed, 18 insertions, 0 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 7974a05a816..ef351bb664c 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -65,6 +65,9 @@ CONFIGURE_ARGS+=--enable-dom \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
+
+USE_PHP= spl
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "exif"
@@ -198,6 +201,9 @@ CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
USE_MYSQL= yes
DEFAULT_MYSQL_VER= 41
BROKEN_WITH_MYSQL= 323 40
+
+USE_PHP= spl
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "ncurses"
@@ -395,6 +401,9 @@ USE_PHP= session
USE_PHP_BUILD= yes
PHP_HEADER_DIRS=libsqlite/src
+USE_PHP= spl
+USE_PHP_BUILD= yes
+
OPTIONS= UTF8 "Enable UTF-8 support" off
.endif
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 7974a05a816..ef351bb664c 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -65,6 +65,9 @@ CONFIGURE_ARGS+=--enable-dom \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
+
+USE_PHP= spl
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "exif"
@@ -198,6 +201,9 @@ CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
USE_MYSQL= yes
DEFAULT_MYSQL_VER= 41
BROKEN_WITH_MYSQL= 323 40
+
+USE_PHP= spl
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "ncurses"
@@ -395,6 +401,9 @@ USE_PHP= session
USE_PHP_BUILD= yes
PHP_HEADER_DIRS=libsqlite/src
+USE_PHP= spl
+USE_PHP_BUILD= yes
+
OPTIONS= UTF8 "Enable UTF-8 support" off
.endif