aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/mednafen/Makefile2
-rw-r--r--emulators/mednafen/distinfo6
-rw-r--r--emulators/mednafen/files/patch-src_Blip_Buffer.cpp25
3 files changed, 29 insertions, 4 deletions
diff --git a/emulators/mednafen/Makefile b/emulators/mednafen/Makefile
index 03d0f39b0c0..9b543ab5517 100644
--- a/emulators/mednafen/Makefile
+++ b/emulators/mednafen/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mednafen
-PORTVERSION= 0.6.3
+PORTVERSION= 0.6.4
CATEGORIES= emulators games
MASTER_SITES= http://mednafen.com/releases/
diff --git a/emulators/mednafen/distinfo b/emulators/mednafen/distinfo
index 4e5c59ae07b..770c61cf46d 100644
--- a/emulators/mednafen/distinfo
+++ b/emulators/mednafen/distinfo
@@ -1,3 +1,3 @@
-MD5 (mednafen-0.6.3.tar.bz2) = 34ae77769f6ffa5fd6426930cb33be1a
-SHA256 (mednafen-0.6.3.tar.bz2) = e7a1bf6c35fbac83d0d5070ef76000638b4295ae70bb3efdcd0db9bbf7855111
-SIZE (mednafen-0.6.3.tar.bz2) = 1564472
+MD5 (mednafen-0.6.4.tar.bz2) = 00ae6624d2e674c8a77ab4ea0086c17c
+SHA256 (mednafen-0.6.4.tar.bz2) = 149de61fc5dc1b34054a931438ecb22307a5c333e52826dfa98180a873608cbe
+SIZE (mednafen-0.6.4.tar.bz2) = 1518068
diff --git a/emulators/mednafen/files/patch-src_Blip_Buffer.cpp b/emulators/mednafen/files/patch-src_Blip_Buffer.cpp
new file mode 100644
index 00000000000..dfa4d62fd70
--- /dev/null
+++ b/emulators/mednafen/files/patch-src_Blip_Buffer.cpp
@@ -0,0 +1,25 @@
+--- src/Blip_Buffer.cpp Thu Aug 24 12:12:17 2006
++++ src/Blip_Buffer.cpp Thu Aug 24 12:12:48 2006
+@@ -190,16 +190,16 @@
+ treble = 5.0;
+
+ long double const maxh = 4096.0;
+- long double const rolloff = powl( 10.0, 1.0 / (maxh * 20.0) * treble / (1.0 - cutoff) );
+- long double const pow_a_n = powl( rolloff, maxh - maxh * cutoff );
++ long double const rolloff = pow( 10.0, 1.0 / (maxh * 20.0) * treble / (1.0 - cutoff) );
++ long double const pow_a_n = pow( rolloff, maxh - maxh * cutoff );
+ long double const to_angle = pi / 2 / maxh / oversample;
+ for ( int i = 0; i < count; i++ )
+ {
+ long double angle = ((i - count) * 2 + 1) * to_angle;
+- long double c = rolloff * cosl( (maxh - 1.0) * angle ) - cosl( maxh * angle );
+- long double cos_nc_angle = cosl( maxh * cutoff * angle );
+- long double cos_nc1_angle = cosl( (maxh * cutoff - 1.0) * angle );
+- long double cos_angle = cosl( angle );
++ long double c = rolloff * cos( (maxh - 1.0) * angle ) - cos( maxh * angle );
++ long double cos_nc_angle = cos( maxh * cutoff * angle );
++ long double cos_nc1_angle = cos( (maxh * cutoff - 1.0) * angle );
++ long double cos_angle = cos( angle );
+
+ c = c * pow_a_n - rolloff * cos_nc1_angle + cos_nc_angle;
+ long double d = 1.0 + rolloff * (rolloff - cos_angle - cos_angle);