aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--biology/py-biopython/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/biology/py-biopython/Makefile b/biology/py-biopython/Makefile
index 8ee594faff6..01312ee26c6 100644
--- a/biology/py-biopython/Makefile
+++ b/biology/py-biopython/Makefile
@@ -17,8 +17,10 @@ RUN_DEPENDS= ${PYNUMPY}
USES= python:2
USE_PYTHON= distutils autoplist
-.if !defined(WITHOUT_REPORTLAB)
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab1>0:${PORTSDIR}/print/py-reportlab1
-.endif
+OPTIONS_DEFINE= REPORTLAB
+OPTIONS_DEFAULT= REPORTLAB
+
+REPORTLAB_DESC= PDF support in Bio.Graphics module
+REPORTLAB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}reportlab1>0:${PORTSDIR}/print/py-reportlab1
.include <bsd.port.mk>