aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/gcc-ooo/Makefile2
-rw-r--r--lang/gcc/Makefile2
-rw-r--r--lang/gcc34/Makefile2
-rw-r--r--lang/gcc35/Makefile2
-rw-r--r--lang/gcc40/Makefile2
-rw-r--r--lang/gcc41/Makefile2
-rw-r--r--lang/gcc42/Makefile2
-rw-r--r--lang/gcc43/Makefile2
-rw-r--r--lang/gcc44/Makefile2
-rw-r--r--lang/gcc45/Makefile2
-rw-r--r--lang/gcc46/Makefile2
-rw-r--r--lang/gcc47/Makefile2
-rw-r--r--lang/gcc48/Makefile2
13 files changed, 26 insertions, 0 deletions
diff --git a/lang/gcc-ooo/Makefile b/lang/gcc-ooo/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc-ooo/Makefile
+++ b/lang/gcc-ooo/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc35/Makefile b/lang/gcc35/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc35/Makefile
+++ b/lang/gcc35/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc40/Makefile
+++ b/lang/gcc40/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc41/Makefile b/lang/gcc41/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc41/Makefile
+++ b/lang/gcc41/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index d7b65c3a043..2a315db2fd2 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -42,6 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == ia64 || ${ARCH} == sparc64