aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cvsplot/Makefile28
-rw-r--r--devel/cvsplot/distinfo1
-rw-r--r--devel/cvsplot/pkg-comment1
-rw-r--r--devel/cvsplot/pkg-descr5
-rw-r--r--devel/cvsplot/pkg-plist1
6 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f73e3b6e77e..bd74ad17761 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -112,6 +112,7 @@
SUBDIR += cvslines
SUBDIR += cvsmapfs
SUBDIR += cvspadm
+ SUBDIR += cvsplot
SUBDIR += cvsps
SUBDIR += cvsstat
SUBDIR += cvsutils
diff --git a/devel/cvsplot/Makefile b/devel/cvsplot/Makefile
new file mode 100644
index 00000000000..a448120bf54
--- /dev/null
+++ b/devel/cvsplot/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: cvsplot
+# Date created: May 31, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvsplot
+PORTVERSION= 1.6.1
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ gnuplot:${PORTSDIR}/math/gnuplot
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,^#!/usr/bin/perl -w,#!/usr/bin/env perl -w,g" ${WRKSRC}/cvsplot.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cvsplot.pl ${PREFIX}/bin/cvsplot
+
+.include <bsd.port.mk>
diff --git a/devel/cvsplot/distinfo b/devel/cvsplot/distinfo
new file mode 100644
index 00000000000..6c62881f300
--- /dev/null
+++ b/devel/cvsplot/distinfo
@@ -0,0 +1 @@
+MD5 (cvsplot-1.6.1.tar.gz) = a95653f607f8a58900e727732b30dbd0
diff --git a/devel/cvsplot/pkg-comment b/devel/cvsplot/pkg-comment
new file mode 100644
index 00000000000..22725bcceb9
--- /dev/null
+++ b/devel/cvsplot/pkg-comment
@@ -0,0 +1 @@
+A perl script which analyses the history of a CVS-managed project
diff --git a/devel/cvsplot/pkg-descr b/devel/cvsplot/pkg-descr
new file mode 100644
index 00000000000..d3f5fa3a11c
--- /dev/null
+++ b/devel/cvsplot/pkg-descr
@@ -0,0 +1,5 @@
+Cvsplot is used for collecting statistics from CVS controlled files. Simple
+statistics such as how the total number of files and lines of code change
+against time.
+
+WWW: http://cvsplot.sourceforge.net/
diff --git a/devel/cvsplot/pkg-plist b/devel/cvsplot/pkg-plist
new file mode 100644
index 00000000000..8db3b068578
--- /dev/null
+++ b/devel/cvsplot/pkg-plist
@@ -0,0 +1 @@
+bin/cvsplot