aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/linux-f10-sdl12/Makefile8
-rw-r--r--devel/linux-f8-sdl12/Makefile8
-rw-r--r--devel/linux-sdl12/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/devel/linux-f10-sdl12/Makefile b/devel/linux-f10-sdl12/Makefile
index c25e3cf94f2..9c988a99143 100644
--- a/devel/linux-f10-sdl12/Makefile
+++ b/devel/linux-f10-sdl12/Makefile
@@ -37,8 +37,14 @@ RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
--nodeps --replacepkgs
RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Unfetchable"
+.endif
+
do-install:
@${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
@${LDCONFIG_LINUX}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/linux-f8-sdl12/Makefile b/devel/linux-f8-sdl12/Makefile
index c25e3cf94f2..9c988a99143 100644
--- a/devel/linux-f8-sdl12/Makefile
+++ b/devel/linux-f8-sdl12/Makefile
@@ -37,8 +37,14 @@ RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
--nodeps --replacepkgs
RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Unfetchable"
+.endif
+
do-install:
@${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
@${LDCONFIG_LINUX}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/linux-sdl12/Makefile b/devel/linux-sdl12/Makefile
index c25e3cf94f2..9c988a99143 100644
--- a/devel/linux-sdl12/Makefile
+++ b/devel/linux-sdl12/Makefile
@@ -37,8 +37,14 @@ RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
--nodeps --replacepkgs
RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Unfetchable"
+.endif
+
do-install:
@${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
@${LDCONFIG_LINUX}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>