aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/weedit/Makefile2
-rw-r--r--sysutils/weedit/files/patch-utils__readdb.c11
-rw-r--r--sysutils/weedit/files/patch-weedit.c11
3 files changed, 24 insertions, 0 deletions
diff --git a/sysutils/weedit/Makefile b/sysutils/weedit/Makefile
index 6bc08b8214c..a1984c396e4 100644
--- a/sysutils/weedit/Makefile
+++ b/sysutils/weedit/Makefile
@@ -15,6 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= File duplicate scanner with database support
+USE_DOS2UNIX= yes
+
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/sysutils/weedit/files/patch-utils__readdb.c b/sysutils/weedit/files/patch-utils__readdb.c
new file mode 100644
index 00000000000..37450083e7e
--- /dev/null
+++ b/sysutils/weedit/files/patch-utils__readdb.c
@@ -0,0 +1,11 @@
+--- ./utils/readdb.c.orig 2011-06-21 15:44:50.000000000 +0200
++++ ./utils/readdb.c 2011-06-21 15:45:08.000000000 +0200
+@@ -9,7 +9,7 @@
+ #include <stdio.h>
+ #include <memory.h>
+ #include <time.h>
+- int main(unsigned int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ unsigned long fsize, fcount, ccount, offset, offset2, i;
+ unsigned char *db;
diff --git a/sysutils/weedit/files/patch-weedit.c b/sysutils/weedit/files/patch-weedit.c
new file mode 100644
index 00000000000..fef7d072efe
--- /dev/null
+++ b/sysutils/weedit/files/patch-weedit.c
@@ -0,0 +1,11 @@
+--- ./weedit.c.orig 2011-06-21 15:45:47.000000000 +0200
++++ ./weedit.c 2011-06-21 15:45:23.000000000 +0200
+@@ -265,7 +265,7 @@
+ exit (-1);
+ }
+
+-int main(unsigned int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ float timeval;
+ unsigned long i;