aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/gnokii/Makefile2
-rw-r--r--graphics/libafterimage/Makefile1
2 files changed, 2 insertions, 1 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 0d441dfd51c..a82e1095a29 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE} --enable-security \
--with-xgnokiidir=${PREFIX}/share
CONFIGURE_ENV+= MSGFMT="${LOCALBASE}/bin/msgfmt" \
XGETTEXT="${LOCALBASE}/bin/xgettext" \
- CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include -fPIC" \
LIBS="-L../common -L${LOCALBASE}/lib"
MAN1= gnokii.1 todologo.1 ppm2nokia.1 sendsms.1
diff --git a/graphics/libafterimage/Makefile b/graphics/libafterimage/Makefile
index 241ce0d3fd7..6a4aaec03de 100644
--- a/graphics/libafterimage/Makefile
+++ b/graphics/libafterimage/Makefile
@@ -32,6 +32,7 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --enable-sharedlibs --with-builtin-xpm --with-x
+CFLAGS+= "-fPIC"
INSTALLS_SHLIB= yes
MAN1= ascompose.1x